I've been fighting with this for a couple of weeks when booting my PC:

Error keyboard or no keyboard present CMOS checksum error -Default loaded

And of course there is no way to go any further since I am requested to HIT either F1 or ENTER on my (not present?) KEYBOARD.

Everything started after PROPERLY removing my USB drive from one of the front ports of my PC (Vista Ultimate). The mouse and the keyboard suddenly stopped working and I had to restart the PC.

Please consider that my USB keyboard is just PERFECT. I've already connected to another working PC and it does work.

This is what I've already tried by now:

  1. Turning the PC off and disconnecting EVERYTHING from the back.
  2. Disconnecting the two SATA hard drives from the motherboard.
  3. Pushing the "Reset BIOS" button in the motherboard and waiting a long time (are 12 hours enough?) before reconnecting and rebooting.
  4. Removing the BIOS battery and waiting a long time before putting it back and resetting the BIOS.
  5. Replacing the BIOS battery with a new one (plus resetting the BIOS).

I just don't know what else to disconnect, reset or replace. Maybe me? o.O

Please help!!!


Have you tried all the USB ports on your computer? Maybe you blew out one (or all) of the USB controllers.

I would connect a PS2 keyboard if you have one (or borrow one) so you can boot and check the status of your USB ports.

  • Thanks for your reply. I haven't tried all of them. This will be my next step. I'll let you know. PS2 keyboard or mouse are not recognized at all... – user18641 Nov 19 '09 at 20:34
  • Well, Jack. I've left the same old CMOS battery in place, reset the BIOS and connected the keyboard in another USB port. This time there was no keyboard error, just the checksum one (which is allegedly related to a weak battery). So my USB keyboard is working again! And just to be sure that the first USB port was blown, I tried plugging my USB mouse into it... and the mouse is working too! o.O Final test: I've connected everything just as it was before the failure (that is, the USB keyboard into the "blown" port) AND EVERYTHING IS WORKING FINE! What the well is going on in here? – user18641 Nov 19 '09 at 21:11
CMOS checksum error -Default loaded

Is the CMOS battery dead?

  • Do you mean the BIOS battery or there is another one? I've replaced the BIOS battery with a new one and it was all the same. – user18641 Nov 19 '09 at 21:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy