38

I am using Fedora 20 with Gnome. The screen Power Savings blanks the screen after 15 minutes and then the screen gets automatically locked. I'd like to have the screen blanked and locked after an hour, but the pop-up only goes up to 15 minutes. Is there any way to make it an hour?

2 Answers 2

60

You can put the desired values directly in GSettings, either via the dconf-editor app (i.e. "GNOME regedit") or command line:

  • Timeout for blanking the screen (seconds; 0 = never):

    gsettings set org.gnome.desktop.session idle-delay 3600
    
  • Timeout for locking the screen after blanking (seconds; 0 = instant):

    gsettings set org.gnome.desktop.screensaver lock-delay 0
    
5
  • 1
    That is great. Is there anyplace where all of this is documented?
    – vy32
    Mar 11, 2014 at 0:16
  • 2
    Probably not. But the schemas and keys themselves do have descriptions, visible in dconf-editor.
    – user1686
    Mar 15, 2014 at 9:26
  • And you can also get the current settings via: gsettings get org.gnome.desktop.screensaver lock-delay Nov 6, 2015 at 20:10
  • 5
    Just for the sake of completion, there is also org.gnome.desktop.screensaver lock-enabled for just enabling/disabling the locking. If you set this to false, the lock-delay will be ignored. Jan 25, 2016 at 6:38
  • If you run the above commands from an SSH session and gets a warning about spawning dbus you need to either launch dbus or use terminal in the local session. Jun 4, 2017 at 19:10
7

This can also be accessed by using:

  • Settings -> Privacy

    screenshot

3
  • 1
    I only see the lock-delay option, worded as "Lock screen after blank for", and not the idle-delay option, which is what most people probably want to control.
    – kbolino
    Aug 6, 2017 at 15:08
  • This suggestion indeed presents the pull-down for idle duration before lock screen starts. However, the OP wanted to know how to set it for 1 hour; the pull-down stops at 15 minutes.
    – kronenpj
    Jan 13, 2018 at 21:05
  • In Ubuntu 17.10 (which uses the GNOME Shell interface), it goes up to 1 hour... Jan 30, 2018 at 18:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.