1

I am using MonoDevelop. As soon as I open a project it shows this error:

Project does not support framework .NETFramework,Version=4.0

How can I solve this problem?

5
  • 1
    Can you post the contents of the .vbproj file in a pastebin? Most likely the problem is that your Mono version is too old; Ubuntu does not update mono to the latest version which is 3.2.3. You would have to install a more updated Mono from an unofficial PPA, or compile it yourself. Likewise for monodevelop. 2.10.x series of Mono is very old now. You may be able to reduce the targeted mono version on your project in order to get it working, but this may remove features your code needs. Mar 11, 2014 at 14:34
  • here is the version: i.stack.imgur.com/XelxL.png
    – Terminal
    Mar 11, 2014 at 14:35
  • Not helpful, and not what I asked for. Mar 11, 2014 at 14:38
  • 1
    Does the version of Mono your installing support the version of VB.NET contained in the .NET Framework 4.0? If it does not you will have to change the .NET Framework to something that is supported. This sounds like a Stackoverflow question to be honest. The error is specific, it can't compile, because .NET Framework 4.0 isn't supported.
    – Ramhound
    Mar 11, 2014 at 14:38
  • Please provide me one more information,if i can program vb.net and c# in Net Beans 7.0 available in software center.thanks.
    – Terminal
    Mar 11, 2014 at 14:45

0

You must log in to answer this question.

Browse other questions tagged .