11

I accidentally pressed Ctrl + Alt + Down (Windows 7) when a second display was connected and flipped all the screen orientations. I quickly pressed Ctrl + Alt + Up to restore it but the second monitor did not switch back and is now stuck in the wrong orientation; no matter what orientation I switch the system to.

I tried disconnecting and reconnecting the monitor but that did not help. (Actually after one disconnect/reconnect it got stuck rotated 90 degrees clockwise, but now it seems to have settled on being stuck upside down.)

I then rebooted the machine but that also did not help.

How can I fix this?

Is there display orientation information hidden in the registry somewhere that I can manually delete / reset?

  • 2
    Similar problem for Windows 10 - Solved! All settings --> System --> Display --> click on the monitor (1 or 3) and change the orientation to Landscape. – user690261 Jan 26 '17 at 11:11
8

This is a feature of either your video driver or a utility installed on your system.

Because you mentioned that Ctrl+Alt+Up does not work, it's possible that shortcut was assigned to a different program. Unfortunately, in Windows there is no way to look up what program has grabbed a given keyboard shortcut, but you can try closing all other programs and utilities to see if it becomes freed up again, in which case it would start working for the display driver utility.

As mentioned in @Taylor's answer, you can also try clicking on the wrongly-oriented desktop first, in case that desktop has lost focus and the utility is trying to reorient a different monitor which is already oriented correctly.

If none of the above work, the rotation setting may be accessible via one of your system tray icons. If it isn't, you can try to find it in the control panel:

  1. Open the Screen Resolution control panel (e.g., right-click on a blank area of your Desktop and select Screen Resolution)
  2. Click on the monitor that's in the wrong orientation.
  3. Click Advanced Settings.
  4. In the dialog that opens, you'll see several tabs: Adapter, Monitor, Color Management, and maybe some other tabs. Check the other tabs for orientation settings. For example, if you have an Intel graphics chip, you'll have a tab like this, which includes a Rotation setting:

intel rotation setting in screen resolution control panel

If this doesn't work, then in the worst-case scenario you can fix the issue by uninstalling and reinstalling the video driver.

| improve this answer | |
  • Ah, I didn't realize that wasn't a normal Windows shortcut. Thanks. I was able to fix it by switching to cloned desktop then back to extended (I could've done this through the normal control panel but I didn't think of it until I opened the driver control panel, which I wouldn't have done without your answer). P.S. Great edit, thanks! – Jason C Mar 11 '14 at 18:34
  • The Ctrl + Alt + Arrow keyboard shortcut, btw, appears to be a direct shortcut to the "Rotation" setting in that dialog -- I have Intel graphics too. Turns out the shortcuts are fully configurable there (at least, in the version of the drivers that I have). I have disabled those keyboard shortcuts in the Intel control panel, so I can't screw that up again -- they're the exact same shortcuts as desktop switching on Ubuntu, I'm always getting confused. – Jason C Mar 11 '14 at 18:38
  • 1
    Glad you fixed it! Good to know the keyboard shortcut is linked in that way. You might also be able to disable it by unchecking the Show Tray Icon checkbox in the dialog. I have a different utility for positioning windows and moving them between my screens, and I think I disabled the Intel graphics tray icon a while back to prevent it from hijacking some hotkeys such as Ctrl+Alt+Arrow. – rob Mar 11 '14 at 18:48
  • Before embarking on the above, maybe try Taylor's solution below... – notAChance Oct 2 '17 at 16:00
  • 1
    @xeon48 it isn't clear whether Taylor's answer would have helped the OP, but I have updated my answer to mention Ctrl+Alt+Up issues and reference Taylor's answer for completeness. – rob Oct 2 '17 at 19:35
8

I found that the hotkey only affects the last "Active" Monitor. Try clicking the problem monitor and trying the hotkey again. Ctrl + Alt + Up should revert to normal.

| improve this answer | |
  • I feel THIS should be the answer and the accepted one was total overkill. – notAChance Oct 2 '17 at 16:00
  • 1
    @xeon48 This is, indeed, the fastest solution--if it works. But as stated in the question, the OP (Jason C) immediately tried Ctrl + Alt + Up after pressing Ctrl + Alt + Down, so it isn't clear that this would have helped. Also keep in mind that Ctrl + Alt + Up may have been assigned to a different program or action, preventing the display driver utility from using that keyboard shortcut. – rob Oct 2 '17 at 19:05
  • consider turning off the hot key too SU:/a/588469 – SpeedCoder5 Sep 8 '19 at 14:28
2

I had a similar problem, tried everything but no good.

By making the screen that was wrongly rotated the main screen, I was able to then change it from portrait to landscape, which fixed the rotation issue. Then I made the other screen the main one as I like it.

| improve this answer | |
0

GO to Display> Screen resolution, by right clicking on the desktop and clicking on screen resolution In Display click on your second monitor in the orientation box you will see that the setting is landscape (flipped). Change to just "landscape" Click apply and ok/

Should be good. Had the same prob. Im on WIN 7, but it should be basically the same.

| improve this answer | |
-1

Right click on either monitor > graphics options > rotation > select monitor you want > select rotation angle.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.