4

When I'm on Linux and I reboot the machine and choose to boot on Windows 7, the keyboard and mouse are turned off, like they aren't receiving power. After another reboot they work fine (unplugging and plugging doesn't work, reboot is the only way), but it's pretty annoying and it's also not good for the machine.

The reboot can be done once Windows started, but I have to use the machine's reset button, ctrl alt delete obviously doesn't work. It can, however, be done with ctrl alt delete during the BIOS phase.

This doesn't happen when going from Windows to Windows, or Windows to Linux.

What can be causing this? What can I do to fix it?

  • When you boot up and they don't work try unplugging the USB and plugging them back in again. See if that solves it. – Matthew Williams Mar 12 '14 at 11:06
  • @MatthewWilliams I forgot to mention that doesn't solve it. – ChocoDeveloper Mar 12 '14 at 11:07
  • How often do you reboot? Maybe it's better to replace either windows or linux by a virtual machine? I would try to make a BIOS update and make a cmos reset after it. Try toggeling "USB legacy support" in BIOS. – davidbaumann Apr 21 '14 at 20:19
  • @davidbaumann Once or twice a day. I use windows for games and linux for work/life. I don't think games will run smoothly in a VM, and I don't want to have my work/life in a VM under a windows host either. I updated the BIOS but nothing changed. I didn't reset it though, I'm not sure it's safe. Another detail: When I shut down linux, sometimes it shuts down correctly but then it turns on again. What sorcery is this? – ChocoDeveloper Apr 23 '14 at 20:06
4

TL;DR:

Try installing USB drivers appropriate for your motherboard.

Long version:

I had a very similar problem. For me, any time I booted into Linux, my USB devices wouldn't work in Windows. For me, rebooting did not fix usb. Maybe this will help you.

I was using the generic Windows 7 drivers for USB, and I found a similar question on a different site: https://askubuntu.com/questions/410596/no-usb-devices-picked-up-on-restart-to-windows-7-from-ubuntu

For me, going to my motherboard manufacturer's website and installing the USB 3 drivers worked. So, perhaps you could fix the problem by going to your motherboard/laptop manufacturer's site and installing some USB drivers specific to your computer.

  • Wow thanks! Changing the XHCI option from smart auto to auto (as explained in your link) fixed it for me. But I had already updated the BIOS, so that might have helped too. – ChocoDeveloper May 28 '14 at 16:33
0

Just changing bios USB XHCI from smart auto to auto works on my Asus Maximus MB. (Which begs the question what's smart about smart auto!)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.