Normally, this should not be a problem. But usually, it always is. The Memtest86+ website hosts a specially prepped EXE auto-installer file that will format your USB flash drive, copy Memtest86+ binaries to it and make it bootable.


It's packed as a ZIP file and should work with Windows 7. The name of the file you run is Memtest86+ USB Installer.exe but I am having no luck with it today. Simply because I am unable to select my USB flash drive from the drop down menu. The menu is not showing any selectable item.


I tried version 5.01 and 4.20 on Windows 7 and got the same results. Can't select my USB flash drive. The flash drive is a SanDisk 4 GB Cruzer Blade, just unwrapped, brand new. I had it formatted with FAT32 inside Explorer to get rid of the extra software that SanDisk puts on it. I also rebooted Windows to make sure drivers are loaded. I can use the flash drive to copy files back and forth effortlessly, it just won't show up in the Memtest86+ prep tool.

I did try downloading the pre-compiled bootable binary for version 5.01 and tried to prep the USB flash drive with it using Linux Pen Drive. Inside this tool (Universal-USB-Installer- I selected "Try Unlisted Linux ISO". I got the same problem here. The USB flash drive is just not showing up.


However! Inside this tool you can select "Show all Drives". That way I can select my USB flash drive and hit the Create button.


It starts working on it but then returns an error. Some files are copied to the USB flash drive.


What else can a man do to get this thing working?

Logs are always nice...

Closing All Open Explorer Windows
Extract: C:\Users\SUPPOR~1\AppData\Local\Temp\nskE617.tmp\fat32format.exe... 100%
Formatting G: as Fat32
Warning ALL data on drive 'G' will be lost irretrievably, are you sure
(y/n) :Size : 4GB 7821280 sectors
512 Bytes Per Sector, Cluster size 2048 bytes
Volume ID is 13f8:1e63
32 Reserved Sectors, 15217 Sectors per FAT, 2 fats
1947703 Total clusters
1947702 Free Clusters
Formatting drive G:...
Clearing out 30470 sectors for Reserved sectors, fats and root cluster...
Wrote 15600640 bytes in 6.45 seconds, 2.31 Megabytes/sec
Initialising reserved sectors and FATs...
Extract: C:\Users\SUPPOR~1\AppData\Local\Temp\nskE617.tmp\syslinux.exe... 100%
Extract: C:\Users\SUPPOR~1\AppData\Local\Temp\nskE617.tmp\syslinux.cfg... 100%
Extract: C:\Users\SUPPOR~1\AppData\Local\Temp\nskE617.tmp\7zG.exe... 100%
Extract: C:\Users\SUPPOR~1\AppData\Local\Temp\nskE617.tmp\7z.dll... 100%
Extract: C:\Users\SUPPOR~1\AppData\Local\Temp\nskE617.tmp\chain.c32... 100%
Extract: C:\Users\SUPPOR~1\AppData\Local\Temp\nskE617.tmp\menu.c32... 100%
Extract: C:\Users\SUPPOR~1\AppData\Local\Temp\nskE617.tmp\vesamenu.c32... 100%
Extract: C:\Users\SUPPOR~1\AppData\Local\Temp\nskE617.tmp\mbrid
Create folder: G:\uui
Copy to G:\uui\syslinux.cfg
Executing syslinux on G:
Execute: C:\Users\SUPPOR~1\AppData\Local\Temp\nskE617.tmp\syslinux.exe -maf -d /uui G:
Syslinux Errors 0
Creating Label UUI on G:
Extracting the iso: The progress bar will not move until finished. Please be patient...
Execute: "C:\Users\SUPPOR~1\AppData\Local\Temp\nskE617.tmp\7zG.exe" x "C:\Users\support24\Downloads\memtest86+-5.01.iso\memtest86+-5.01.iso" -o"G:\" -y -x![BOOT]*
Editing Configuration Files
Extract: C:\Users\SUPPOR~1\AppData\Local\Temp\nskE617.tmp\Uni-USB-Installer-Copying.txt... 100%
Extract: C:\Users\SUPPOR~1\AppData\Local\Temp\nskE617.tmp\Uni-USB-Installer-Readme.txt... 100%
Extract: C:\Users\SUPPOR~1\AppData\Local\Temp\nskE617.tmp\license.txt... 100%
C:\Users\SUPPOR~1\AppData\Local\Temp\nskE617.tmp\Uni-USB-Installer-Copying.txt -> G:\Uni-USB-Installer-Copying.txt
1 File(s) copied
C:\Users\SUPPOR~1\AppData\Local\Temp\nskE617.tmp\Uni-USB-Installer-Readme.txt -> G:\Uni-USB-Installer-Readme.txt
1 File(s) copied
C:\Users\SUPPOR~1\AppData\Local\Temp\nskE617.tmp\license.txt -> G:\license.txt
1 File(s) copied
Checking if we need to replace vesamenu.c32, menu.c32, and chain.c32
Installation Done, Process is Complete!
  • 2
    I found this guide on PassMark website (current owners of the original Memtest86 program) and they also tell you to run (their own) specially prepped USB tool. It's the same basic idea. – Samir Mar 12 '14 at 11:37

Skip Memtest86+! Go to Memtest86! Run! Done!

I've done what was asked of me, and according to the authors website. But it didn't work anyway. So what I have done is I used another Memtest 86 program. The original Memtest86 line, now up in version 5 (new free software license), and owned by PassMark. It was a breeze using it and making the UFD bootable. It's as simple as ABC.

  1. Go to Memtest86.com.
  2. Click on the link "Image for creating bootable USB Drive". This will download the file http://www.memtest86.com/downloads/memtest86-usb.zip for Windows.
  3. Unpack the ZIP file.
  4. Run the imageUSB.exe file and follow onscreen instructions.

This should work on both BIOS and UEFI BIOS systems. On UEFI systems you can even use the mouse pointer to navigate.


a b c d e f


12:38:47:845 - PassMark Software - imageUSB v1.1.1013
12:38:47:845 - Getting list of available removable USB drives...
12:38:47:845 - Inspecting Drive C:\...
12:38:47:845 - Inspecting Drive D:\...
12:38:47:845 - Inspecting Drive E:\...
12:38:47:861 - Inspecting Drive F:\...
12:38:47:861 - Inspecting Drive G:\...
12:38:47:861 - Ready...
12:39:56:377 - Drive G:\ added to queue.
12:39:56:392 - Note: Disk image was not created with imageUSB previously.
     Image file does not contain a valid checksum. Verification will be calculated from source image.
12:39:56:423 - Writing image C:\Users\support24\Downloads\memtest86-usb\memtest86-usb.img to G:\ (drive 1)
12:40:57:155 - Drive G:\ write completed.
12:40:57:623 - Verifying written image on Drive G:\
12:41:08:373 - Drive G:\ checksum completed.
12:41:08:373 - MD5 matched. (G:\).
     MD5 (Drive) : C7C53FCA0E9C1A6751FBB36E205D4F4A
     MD5 (Image) : C7C53FCA0E9C1A6751FBB36E205D4F4A
12:41:08:389 - SHA1 matched. (G:\).
     SHA1 (Drive) : 220A1073EE96D489AB4E9A44E90E7670AFE7EE03
     SHA1 (Image) : 220A1073EE96D489AB4E9A44E90E7670AFE7EE03

You can see it had some issues with checksums but it was false alarm, verification passed.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.