21

I have a VirtualBox instance (running under Mac OS X 10.5) and Windows 7 running in VirtualBox. Everything is otherwise fine, but I cannot understand how to use shared folders. I have added a shared folder in the VM configuration in VirtualBox, but I cannot for the world of me understand how do I access the shared folder in Windows 7.

Other instructions seem to talk about the network, and that my VirtualBox should somehow show up in the network and expose shared folders there. But I do not see anything that looks like VirtualBox in the Network in Windows Explorer. What do I look for?

1
  • Saw this same problem with Windows 10, and the chosen solution worked for that as well. Commented Jul 22, 2019 at 18:19

8 Answers 8

18

Typically it just shows up a fake-virtual-server on the network - you can access it as though you would a file share on some real server. The name is VBOXSVR.

\\Vboxsvr\share_name

I haven't tested Win7 yet, but I have used this functionality on everything from Win200 through 2003. Do you have the guest additions installed?

7
  • 1
    I do have guest additions installed. \\vboxsvr does not show up in my network servers list, and does not exist when I enter it manually.
    – Jaanus
    Commented Nov 19, 2009 at 21:23
  • 1
    VboxSvr is part of its own workgroup, so you may need to browse the entire network - also, for some reason (probably because it doesn't have an IPC$ share) it doesn't like connections directly to it - you need to connect to a specific share.
    – Goyuix
    Commented Nov 20, 2009 at 14:52
  • 1
    I’ll be damned... \\vboxsvr\sharename indeed opened up the share. Yay. I could not browse to it, but I just punched in the name and it came up. So, the last question I have... is there any way to bookmark/map it? I can’t see a UI control that would map it as drive or put it in favorites. I don’t want to type it in every time.
    – Jaanus
    Commented Nov 21, 2009 at 0:00
  • 1
    OK, response to my last comment... when looking at the directory, right click on “Favorites” in left pane and select “Add current location to favorites”.
    – Jaanus
    Commented Nov 21, 2009 at 0:02
  • 2
    @Goyuix Reinstalled/Upgraded VirtualBox Additions (Click Devices menu > Install Virtual Box Additions image...) on the one it wasn't working on and that fixed it.
    – Caltor
    Commented Sep 9, 2015 at 11:47
3

This is what worked for me.

  1. On the host computer right click the folder you want to share, go to Properties->Local Network share->Share this folder. If the host computer is Linux like mine, you have to install Samba. Do this on either from the terminal or from the Software Center.
  2. On Windows 7 on your VM go to Devices (at the menu bar)->Add Guest Additions.
  3. On your VM go to Start->Computer.
  4. At the top part click on Map network drive.
  5. Choose the shared folder under VBOXSVR.
2
  • This did the trick, my shared folders show up now after installing guest additions.
    – zar
    Commented Jan 11, 2017 at 16:24
  • If that may help, in Windows 10 go to File Explorer -> tab "Computer" to find "Map network drive" Commented Aug 9, 2018 at 13:19
3

Once you've added your Shared Folders in Settings of your Windows VM, they should appear.

If they not, you need to install Virtual Guest Additions on your virtual machine, by selecting Insert Guest Additions CD Image from the Devices menu (on your running VM window). After that, shared folders should be available once your Windows machine is fully booted.

0
1

@Jaanus When you enter "Computer" (Start, Computer) you will find a button at the top called "Map Network Drive", click it and add the share link in there, then you'll have a drive that will always appear in "Computer", you can also take a shortcut of it.

http://www.itfall.com/virtualbox-windows-7-shared-folders/

1

Under Networking, I had to fix this by adding the Host Only Adapter as one of my network adapters. I also enabled promiscuity (Allow all) on the other network adapter!

Once I did this, the shares started working properly.

0

I met this problem when running Windows 10 on VirtualBox. It was resolved after combining some actions mentioned in different answers.

I set the Folder Name as Downloads, checked "Auto-mounted" and "Make Permenant" in Device -> Shared folder setting.

Under Networking, I had to fix this by adding the Host Only Adapter as one of my network adapters. I also enabled promiscuity (Allow all) on the other network adapter!

Only with this setting, I couldn't see my shared folder.

electing Insert Guest Additions CD Image from the Devices menu

Then, I found "CD Drive (D:) VirtualBox Guest Additions" appears next to "Local Disk (C:)" in "This PC". I ran VBoxWindowsAddition inside it. The setup will run and ask you to reboot the machine.

When the reboot was done, I can see the "VBOXSVR" computer in "Network". The driver "\\VBOXSVR\Downloads" is the shared folder that I'm looking for.

0

To connect the VM directly to your network and access all network-wide shared folders normally, add a Bridged Network Adapter to the machine's settings.

enter image description here

1
  • Quick note to others that this will open the VM up to lots of network traffic once it is connected to the internet (think Microsoft servers, etc.). In my case doing a shared folder and enabling Guest Additions was the way to go. I can easily share files that way without an internet connection on the guest.
    – inostia
    Commented Aug 17, 2021 at 2:16
0

I couldn't get the shared folder to work, but I found a workaround, at least for copying files from the host to the virtual machine - created an ISO file with http://www.freeisocreator.com/ and mounted the ISO as an optical disk in the virtual machine (also Windows 7 in my case).

Now I have yet to figure out how to transfer files from virtual to host. USB memory stick isn't an option - not recognised by the virtual thing. Maybe through the internet if I can get the internet to work.

Why is there so much hassle with these seemingly simple things!?

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .