0

I was working on my server one minute, the next minute for what appears to be no reason at all, i can't connect to any of my servers via FTP. I've been trying for 4 hours so far to find a solution.

I'm on OS X 10.8.5 and use Transmit for FTP.

Things i've tried already:

  1. Downloaded Filezilla and tried connecting on this, but the same problem occurs. It appears to detect the server, but won't connect.

  2. Browser based FTP, and this works fine.

  3. I tried turning on and off the firewall on OS X (this was not on)

  4. Can't connect to FTP using ipad.

  5. Restarting every device: my computer, ipad, my modem and router.

It would be great if anyone can help, or push me in the right direction.

  • @shoveshed - at point nr 5 you said you reset every device, do you mean factory reset? Also, are you able to ping your hostname? – Rudolph Mar 12 '14 at 16:16
  • browser-based ftp could be http with ajax etc etc. What have you done to ensure that the servers are listening on the proper port? Ar they all on one host? Have you contacted their tech support to see if they had a reboot or configuration change? – horatio Mar 12 '14 at 16:36
  • @horatio All different hosts, godaddy, 1&1, ovh. I don't know who to contact because i can't isolate the problem to one specific. – shovelshed Mar 12 '14 at 18:19
  • The servers are different, two unrelated devices can't connect. That means infrastructure: modem, router, ISP port blocking. In both FTP clients, have you tried toggling (on/or off) "FTP passive mode"? – horatio Mar 12 '14 at 18:22
  • @Rudolph sorry i meant "restarted every device". How do i ping my hostname, can you clarify please? – shovelshed Mar 12 '14 at 18:22
0

Are you behind a firewall or using NAT? Try telnet-ing into each server. See if for some reason a port might have mistakenly been closed either by your ISP or a misconfiguration of a firewall. Can you ssh in?

Are you trying the standard ports? FTP-20,21

What about passive FTP? Are ports blocked?

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.