In Skype calls, sooner or later my voice starts cutting in and out; mid sentence my voice will go silent for several seconds, with no quality loss outside of the cut out. Sometimes instead my voice won't cut out, but will skip or stutter.

I can understand everyone else perfectly. In a one-on-one call, Skype will sometimes tell me my connection is slow and then back to fast.

The cutting out isn't repeatable enough to test. Echo soundtest only sometimes reproduces the problem. Skype says my connection is still fast. The problem can happen once when I join a Skype call, or five hours later. It can happen when I'm doing nothing with my network other than Skype, or when I'm playing a multiplier game with people.

It only happens to Skype. No other VOIP program, or anything else has any internet issues.

My internet speeds should be no issue, download is 117Mbps and upload is 34Mbps, according to Speedtest. I use a wired connection, not wireless. My ISP is Optimum Online/Cablevision.

I have used multiple versions of Skype, the problem continues regardless of version, currently I am on Skype 6.9.

I use Comodo Firewall and Peerblock. I have disabled and uninstalled them multiple times, this does nothing.

It isn't my mic. I have tested my current mic a thousand times and playback is flawless. I have switched to an older mic, no difference.

Doesn't seem to be my computer, I have used my laptop to test if the problem happens, still does even on a wireless connection. I even did a fresh install on my computer earlier. I'm still game to try out anything on my computer since I'm so desperate.

Originally I thought it was my router, yet plugging the ethernet cord directly into the modem doesn't stop the problem. I use a Netgear R6300 with dd-wrt firmware.

I replaced the ethernet cord that ran to my computer, still continued.

I even got a new modem, same problem.

I have contacted my ISP, not too much in terms of support. Will be contacting them again.

I have contacted Skype support. Not too helpful either, I sent them some logs of the problem; hopefully that will reveal something.

I tried disabling certain drivers(mostly USB drivers since that is how my mic is connected) to see if something is conflicting. So far, no luck.

From all accounts it seems to be on Skype's end.

  • 1
    reset Skype settings? Change DNS settings? Turn off auto voice level in settings? – user304064 Mar 12 '14 at 18:25
  • @bobSmith1432 I'll reset skype settings since I haven't done it in awhile. I would think reinstalling it would do the job, but hell why not. I disabled these weird DNS service my ISP has, I know next to nothing outside of DNS stuff; I assume I'd have to go into my router to modify? Skype's auto voice level stuff is disabled however sometimes it does change the volume regardless; yet only makes my voice louder has no noticable link with the skipping. – TheDdevil Mar 12 '14 at 18:36

Your computer's noise reduction feature (assuming it has one) may be incorrectly telling Skype to cut out your outgoind sound. I am on a Mac, and have what seems to be the same problem, so here is what I am trying:

  1. I did the "Echo" test to hear a recording of a call, and I could hear my voice cutting out.
  2. I went in to System Preferences -> Sound -> Input tab
  3. I turned off "Use ambient noise reduction".
  4. I did another Echo call, and did not have the cutting out issue.

I don't know whether this will fix the issue the next time I have a long call, but it's at least something to try, if your system has a similar "automatic adjustment" feature that tries to reduce your background noise for callers.


There are so many things in play here that its almost impossible to diagnose.

1) Make sure that your machine isn't RAM'ing out. 2) Make sure that you have plenty of bandwidth and that your ISP isn't throttling or traffic shaping. 3) Make sure of all of these things on the machine of the person you're talking to.

Now then you can try using Google's DNS or OpenDNS instead of your ISP's DNS. Otherwise, welcome to the joys of VOIP. Because these packets get sent out onto the internet like baby sea turtles entering the ocean, its very hard to know exactly why you're having problems.

I will say that several people I know that use Skype have the same complaint. Perhaps you could try testing with a less-popular provider that might have more available bandwidth.

  • 1) Ram shouldn't be an issue. I have too much RAM to begin with, never maxing it out. I have also ran memtest to make sure it's nothing on that end. All the times I have ran it leads to perfect results. 2) What would be an effective measure to make sure I am not being throttled/shaped? 3) While I think that would certainly help, it happens to everyone I talk to. Whether one on one, or in skype group call. Yet none of them get issues with the others. ONly me. – TheDdevil Mar 13 '14 at 5:12

The problems may well come from Skype's network. You can't do anything about that.

I suggest not using skype. Would google hangout work for you and your callers?

  • 1
    Yeah I have long accepted that it can easily be something out of my control. Doesn't stop me from trying. Yet it's such an oddly specific issue, that not many have gotten. I hope Skype support does come through someday and anaylze the logs I have gave them. Sadly, I require skype for work. – TheDdevil Mar 13 '14 at 10:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.