1

Linux Mint 16 Petra 32bit(Xfce) - Sony Viao (Laptop) Model: VGNFS980

I have no 'function key' functionality to control brightness...

When I first booted the live version, the brightness was OK. Upon finishing the actual installation, the screen was dim. No proprietary Drivers are Found in 'driver manager'. Also, I've tried the Grub edits from several tutorials, with no luck.

Please Advise!

0

Try adjusting brightness manually:

echo 100 > /sys/class/backlight/acpi_video0/brightness
echo 80 > /sys/class/backlight/acpi_video0/brightness
echo 60 > /sys/class/backlight/acpi_video0/brightness

If that helps, then you can add one of the lines to /etc/rc.local before exit 0 line so it persists upon reboot.

| improve this answer | |
  • upon entering "echo 100 > /sys/class/backlight/acpi_video0/brightness" I received the message 'no such file or directory' – Xilas Mar 12 '14 at 22:14
  • this obviously means i dont have acpi_video installed. I did however manage to fix the brightness permantly by finding a file: sudo gedit /sys/class/backlight/sony/brightness - then setting it to 7. which is the max brightness intreval, apparently. An error did occur but it still works. – Xilas Mar 12 '14 at 22:45
0

I had the same problem in my Linux mint 17; I used the following step and it worked fine

Its not permanent fix but " if you can't do manually then try it through command line.

Check first

cd  /sys/class/backlight/; ls                       
  dell_backlight  intel_backlight

then change to root permission

   sudo su - root

Then enter the following command. Remember to change number as desired.

echo 250 > /sys/class/backlight/intel_backlight/brightness

Note - Don't change number below 100 at first time(might be completely dark). Try decreasing ur num slowly

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.