6

Laptop is fully charged before I put it to sleep and when I come back more than 12 hours later and resume it, the computer only has around 10% left.

I have used the powercfg lastwake and powercfg -devicequery wake_armed commands to no avail and have also disabled all the wake on LAN (WOL) options.

I checked the event log and after putting the computer to sleep, 3 hours later it wakes up and loops through a constant cycle of going to sleep and after 29 seconds it resumes. Then 1 minute 46 seconds later it goes back to sleep. It keeps repeating this 2 minute 15 minute cycle over 150 times in the log.

There's also a lot of other events logged, but how would I stop my computer from waking up at all unless I explicitly resume it from sleep?

Follow the link to see the eventLog: http://pastebin.com/rqsUTUAj

  • Have you tried researching about computer insomnia? :) – Garrulinae Mar 13 '14 at 4:32
  • Is hibernating your computer an option instead of putting it to sleep? – Garrulinae Mar 13 '14 at 4:44
  • I prefer sleep and I turned hibernation off – yumyumyum Mar 13 '14 at 5:28
  • 1
    I see a lot of Sleep Reason: System Idle. What is your idle time set at (before sleeping)? You could try setting it to none so you need to put the laptop manually to sleep. Maybe the value is corrupted and it's at 1 or 0 minutes (invisible or not) and your laptop decides it didn't complete the start cycle and does a wake-up to finish it. Try changing the value to something else and resetting it to what it was. – Rik Mar 14 '14 at 9:18
  • 1
    I think the problem to has to do with the computer waking to hibernate (since exactly three hours after going to sleep it wakes up, which is the amount of time set before it is to hibernate) and then since there is no user input for roughly two minutes, it goes back to sleep. Somehow the "System unattended sleep timeout" is set to 2 minutes by default and that is why it is looping the 2 minute sleep/resume cycle. I've edited the registry file for that setting and now I can change the "System unattended sleep timeout" setting. – yumyumyum Mar 14 '14 at 17:03
1

Appears to be a related internet adapter problem, try to follow the steps below to try to resolve, if it can not resolve, update the device drivers.

  1. Open the Device Manager(press + R, type devmgmt.msc, hit Enter).
  2. Select your Network adapter.

    enter image description here

  3. Right-click over the device and select Properties.
  4. In the Power Management tab, you have to enable Allow the computer to turn off this device to save power and Windows will turn off the device when not in use so that power couldn’t be wasted.
  • That was already enabled for the network adapter while the problem was occuring. – yumyumyum Mar 13 '14 at 22:00
  • @yumyumyum You can disable the adapter to see if the problem persists? – stderr Mar 13 '14 at 22:07
  • I will try disabling it but I'm not sure that's the problem since the wake came from an unknown source. – yumyumyum Mar 13 '14 at 22:44
  • It isn't the problem with the network adapter since I disabled it and the problem persisted – yumyumyum Mar 14 '14 at 17:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.