Firefox 27.0.1 does not reload my previous tabs until I restore the previous session, even though I have selected the correct settings in options. Each time I look in settings, the setting has been reset to “show my home page”, and not “show my settings from last time”.

It is also really frustrating because Firefox always checks for the compatibility of add-ons even though I have turned that off and disabled the check for compatibility of add-ons.

How can I ensure that the settings I select are kept?


try this:

In the address bar, type "about:config"

when you are warned about dragons, click the "I'll be careful, I promise" box and proceed.

in the list, look for the browser.startup.page property and change the value from 1 to 3. 1 is load homepage, 2 is blank page, 3 is restore previous tabs

Restart firefox and let us know how it went!

  • Well I tried that now and it did not work. It still want to my home page and it always checks the compatability of my addons even though I have disabled that add on. Any other ideas please? – Colin Richards Mar 17 '14 at 15:08
  • @ColinRichards See also How to fix preferences that won't save. There are different options you could try including Reset Firefox which is the easiest. – vWil Mar 19 '14 at 16:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.