3

I have two 2TB drives:

/dev/sde WCD WD20EZRX-00D8PB0 Firmware revision 80.00A80 (new consumer-grade WD Green series)

/dev/sdf WCD WD2002FYPS-01U1B1 Firmware revision 04.05G05 (old pro-grade server power-saving drive)

The first one (sde) is brand new. I have used it only for a few days and it is formatted as ext4.

The second one (sdf) has been used as a backup drive for a few years. It was almost full and ext4-formatted on top of lmv2.

Both drives are connected to the same SAS controller using the same cable and powered using the same cable (Silverstone PP06B-4SATA10). Two SAS drives also share those very same cables.

I am running the following commands on a idle 8-core workstation with 64GB of RAM:

dd if=/dev/zero of=/dev/sdX iflag=nocache oflag=direct bs=4096

For sde the process has completed after 54329.1 seconds at a speed of 36.8 MB/s.

For sdf the process is still running (after 354117 seconds) at a speed of 4.8 MB/s (as reported after kill -USR1).

This means that the very same command takes nearly 8 times more in the old server drive than in the new consumer drive.

Both are "IntelliPower" drives with 64MB cache and it is true that the newer one is expected to be somehow faster (maybe twice as fast, being generous, but 8 times?)

QUESTIONS

  • Is this to be expected given the features of the drives or might it have something to do with age, corruption, formatting, fullness, power, priority, buggy firmware, etc?
  • Do you think this could be a symptom of hardware malfunction?
  • Should I replace the old drive?

UPDATE

Following @MKzero suggestion, I run smartctl and, indeed, it would seem that the drive is kaput. However, when I run smartctl dd was still running...

smartctl -H /dev/sdf
smartctl 6.2 2013-07-26 r3841 [x86_64-linux-3.12-1-amd64] (local build)
Copyright (C) 2002-13, Bruce Allen, Christian Franke, www.smartmontools.org

=== START OF READ SMART DATA SECTION ===
SMART overall-health self-assessment test result: FAILED!
Drive failure expected in less than 24 hours. SAVE ALL DATA.
Failed Attributes:
ID# ATTRIBUTE_NAME          FLAG     VALUE WORST THRESH TYPE      UPDATED  WHEN_FAILED RAW_VALUE
  5 Reallocated_Sector_Ct   0x0033   138   138   140    Pre-fail  Always   FAILING_NOW 490
6

First of all, if you suspect the older drive to have faults, try checking it's smart values. A transfer rate as low as 5 MB/s seems a little bit odd, especially for sequential writing like dd does.

How full the drive is should not matter for hard drives. This is more a concern for SSDs, which tend to get slower after time.

For testing purposes you could try to swap the cables and see if anything changes - using identical cables doesn't mean one of than can't be broken in some way or another.

Also newer drives store data in less space, thus writing to the drive would be faster. And as the drive's technology advances there are better, stable ways for writing data, e.g. error handling or better recording techs to store the same data on less space. More data on less space would of course mean higher transfers.

  • Thanks for your advice. I have run smartctl (please, see update) and, indeed, it would seem that the drive is kaput. – mirix Mar 13 '14 at 10:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.