4

I am trying to create a Homegroup through my wifi network between my

  • PC (Windows 7) and
  • Office Laptop (Windows 8)

When I create a Homegroup network using my PC then I can see all shared files in my laptop but I can't see shared files and even laptop name on my PC.

When I created a Homegroup from my Laptop, I can't see that there is a Homegroup available on my PC.

When I checked control panel -> windows firewall in my office laptop, I saw this image.

enter image description here

I can't even click any of the links in the above form page due to lack of admin privileges.

What could be the problem?

Is it because I don't have admin privileges to my office laptop?

EDIT: I talked with my office admin. He said that there might be problem with my Home PC. He checked my laptop and said there is nothing which is blocking. I checked my home PC, everything looks fine. please give me some points on assumption which might help me to solve this issue. also I can provide more info if needed.

EDIT 2: Just trying provide brief information. From office laptop, I can access already shared common folders like "My pictures", "My videos", "My Documents" etc.. of other Home PC but can't access the folders which I am sharing for example, I have one folder on Home PC which has movies in it. when I right clicked it and said shared in home group (can read/write), I can't access it. I can see that folder from my laptop but I can't access it. there is a error like - "you don't have enough permissions".

From my Home PC, I can't even see my office laptop name in home group.

One of the users in super user chat has told me to do following:

Don't even think about a home group; you are way overcomplicating this... just turn on shared folder for your user account (or for a whole drive) on the computer you're able to ping from the other computer, then type in Windows Explorer: \1.2.3.4\ShareName where 1.2.3.4 is the IP address assigned to the internal NIC of your other computer and ShareName is the name given to the shared folder/drive it's not rocket science.. you don't need something called a home group to get folder sharing working those damn things almost never work anyway because the security settings are always so locked down that it won't let it work

I did same but didn't work for me.

  • the Office Laptop might/probably has stricter firewall rules. have you checked/adjusted the firewall to allow the homegroup traffic? (Note: You may not be able to due to lack of Admin privileges) – Ƭᴇcʜιᴇ007 Mar 13 '14 at 18:34
  • @techie007 yes I think you are right. just now checked windows firewall and I found this. – Mr_Green Mar 13 '14 at 18:41
  • [techie007 in deleted chat] Actually that is showing you the Windows Firewall is "off" for both Private and Public networks. the yellow bar you blanked out is telling you that the firewall is being controller/replaced by another piece of software (probably installed and controlled by your work's IT). So the reason it doesn't work is because there's a FW in the way (just not the Windows Firewall), and you (probably) can't do anything about that because you're not an admin of the system. – Mr_Green Mar 15 '14 at 5:03
  • [techie007 in deleted chat] Example: symantec.com/connect/articles/… – Mr_Green Mar 15 '14 at 5:04
  • @techie007, I talked with my office admin. He said that there might be problem with my Home PC. He checked my laptop and said there is nothing which is blocking. I checked my home PC, everything looks fine. please give me some points on assumption which might help me to solve this issue. also I can provide more info if needed. – Mr_Green Mar 15 '14 at 5:07
5
+100

There are two possible reasons I can see for your problems :

  1. IPv6 is not turned on on both computers and/or in the router
  2. The Windows 8 computer uses a Live login while Windows 7 uses a local one

Both computers should be fully patched, including optional Windows Updates

For the second problem, you will need to change the Windows 8 login to local.

You will also need to fulfill all the HomeGroup Requirements in Windows 8/8.1 :

  • All PCs in the homegroup must each have network sharing turned on.
  • All PCs in the homegroup must each have network discovery turned on for the Private network profile.
  • All PCs in the homegroup must each have the correct date and time set.
  • All PCs in the homegroup must each have a different PC name.
  • All PCs in the homegroup must have the same workgroup name.
  • All PCs in the homegroup must have the services below and their dependencies set to Running (start). They are by default.
    • DNS Client
    • Function Discovery Provider Host
    • Function Discovery Resource Publication
    • HomeGroup Listener
    • HomeGroup Provider
    • Network List Service
    • Peer Networking Grouping
    • Server
    • SSDP Discovery
    • UPnP Device Host
  • All PCs in the homegroup must have their network connection adapter settings below turned on (checked) in its Properties.
    • File and Printer Sharing for Microsoft Networks
    • Internet Protocol Version 6 (TCP/IPv6)
    • Internet Protocol Version 4 (TCP/IPv4)
  • Hey sorry and thanks.. I never got time to test this.. I will mark it as answer when I test it. I don't want to mislead other future readers :). – Mr_Green Mar 23 '14 at 13:48
  • @Mr_Green, that’s very responsible of you, but unfortunately the automatic bounty-assignment may mislead future readers. ¬_¬ – Synetech Mar 25 '14 at 4:54
0

Try going into your advanced sharing options in Network and Sharing Center on your laptop and select all network list. Under public sharing folder options; it may be turned off. I experienced a similar problem. Hope this helps.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.