0

While the command "sudo mount -t hfsplus /dev/sdc1 /home/external3" mounts the hfs file system on the /home/external3 directory on my Ubuntu server, I don't understand how to get it to mount at boot. In other words, if I reboot, I lose connection to the external hfs file system.

I should note that my other external file system (ext4) mounts just fine at boot.

I've tried different configurations in /etc/fstab, but to no satisfactory end.

What am I doing wrong?

1

I'm by no means an expert, but I would think adding the following to /etc/fstab should mount at boot:

/dev/sdc1 /home/external3 hfs defaults 0 0

That being said, I would probably find the UUID of your external hfs drive

sudo blkid

and use that instead, i.e.

UUID= /home/external3 hfs defaults 0 0

I also read somewhere that you might need to try hfsplus instead of hfs as the file system.

What is the line you've added to fstab? Including that might help.

  • Thanks, I tried your suggestions, but so far, no dice. In fstab, I have the following external drive config fo my ext4 file system: /dev/sdb1 /home/external2 ext4 defaults 0 0. When I attempt to automount my hfs file system, I use this in fstab: /dev/sdc1 /home/external3 hfsplus defaults 0 0. I have also tried it with the UUID instead of /dev/sdb1 or sdc1, but still no joy. – user98496 Mar 15 '14 at 18:03

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.