11

How can I stop Windows 7 Home Premium from creating new network names each time I tether my Samsung Tablet to my Laptop using Androids USB Tethering Option?

Yesterday, it was Network 10. Each time I connect, it'll create a new name.

Can I have a single name when I connect using USB?

New name each time

8

Ƭᴇcʜιᴇ007's answer only worked until I restarted my computer but this one works great.

You can try this if you don't mind the network icon not showing that you're connected.

  1. Open Registry Editor (Windows Key+R to bring up the Run dialog, then type regedit and press Enter).
  2. Go to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E972-E325-11CE-BFC1-08002BE10318}.
  3. There are numbered subkeys starting with 0001. Look in each subkey in descending order for the one with the DriverDesc value having your smartphone's RNDIS driver name (same name shown in your Network Connections view as the "Connect using" value).
  4. Once located, create a new DWORD (32-bit) Value.
  5. Enter the name as *NdisDeviceType (remember to include the asterisk sign * in front).
  6. Edit the newly created DWORD value and enter the value data as 1 (Base choice doesn't matter). Click OK.
  7. Once done, disable and re-enable usb tethering

You will no longer get a prompt asking for network location whenever you connect your smartphone, but you will still get the prompt when connecting to other devices.

Important Note: When you are only connected to your smartphone, your computer's network icon will continue to show that you are not connected to any network. However, the internet will still work fine.

  • This one still works as described on Windows 10, the other solutions are deprecated. An artful dodge! – Dominic Cerisano Feb 19 '17 at 20:18
  • 1
    This will disable any UWP app to connect to the internet, but only will allow desktop app to connect to the internet. – dns Apr 9 '18 at 21:10
  • +1 to dns' comment. Especially, you won't be able to open MS Store anymore. – Defd Aug 3 '18 at 4:27
3
  1. Open Network & Sharing Center
  2. Change adapter settings
  3. Right-click on your tethered "Remote NDIS based Internet Sharing Device"
  4. Status
  5. Details
  6. Copy the IPv4 Address, Subnet Mask, Default Gateway & DNS Servers
  7. Again Right-click on your tethered "Remote NDIS based Internet Sharing Device"
  8. Properties
  9. Highlight "Internet protocol version 4 (TCP/IPv4)"
  10. Properties
  11. For Use the following IP address: Enter what you copied earlier from Status/Details here
  12. Click OK
  13. Close all windows

Source

0

I have got the solution for this problem. It's quite simple. You have to just stop automatic proxy detection.

Start → Control Panel → Network and Internet → Internet Options → Connections → LAN Settings

Then uncheck automatic detect proxy and manual proxy both. Then Reset the pc and Boom.

Actually you don't need to detect IP on Windows when tethering because your set already has an IP address that may change according to your network provider and tethering just shares your mobile internet.

Notice: while using LAN internet check box auto detect proxy.

protected by Community Aug 11 '17 at 3:32

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.