1

I have installed vim and macvim using macports, and tried copying over my .vim directory from linux. Neither seems to read anything from that directory: my customizations for folding and indenting aren't working, and :scriptnames shows only the system-wide /usr/share plugin directories are being read.

Any idea what's going on and how to fix it?

2
  • Macvim is not supposed to read anything from /usr/share I suggest you remove both vim and macvim installed via macports and instead install the latest macvim snapshot from the official downloads. – romainl Mar 15 '14 at 7:28
  • By .vim do you mean a subdirectory of your home directory, ~/.vim/? That should work. Do you have a vimrc file, ~/.vimrc? Can you give a specific file that should be sourced but is not? – benjifisher Mar 15 '14 at 15:27
1

The easiest way I found was to add the file I needed to the system vim file that MacVim created on installation. This file can be found using :scriptnames command.

I needed to use pathogen and it was not working placing it in my .vim file in the home directory. I placed the pathogen.vim in the system vim/autoload directory and then pathogen worked without errors.

I found the right directory in /Applications/MacVim.app/Contents/Resources/vim/autoload

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.