1

I try to open a PDF in Skim from Emacs (via Auctex's View command) on MacOSX Mavericks 10.9.2.

When I open Emacs.app by double-clicking or through Spotlight, it fails. Nothing happens. There's no message and no error. But, when I open Emacs from Terminal (~$ open /Applications/Emacs.app or ~$ /Applications/Emacs.app/Contents/MacOS/Emacs), it works. What's going on here?

In both cases the same Emacs.app is running, the exec-path is the same, and the same command is used: /Applications/Skim.app/Contents/SharedSupport/displayline 25 "test.pdf" "test.tex". These files and test.synctex.gz are in my home directory. So, what's different between launching from Terminal and launching by double-clicking?

This used to work before I upgraded to Mavericks, so I wonder whether this is a Mavericks issue. Has someone been able to open Skim from Emacs on MacOSX Mavericks? Has someone seen something similar?

I tried the latest stable Emacs (24.3) from both Homebrew and emacsformacosx.com each time with the same result.

Below is some Homebrew information:

~$ brew doctor
Your system is ready to brew.
~$ brew info emacs
emacs: stable 24.3, HEAD
http://www.gnu.org/software/emacs/
/usr/local/Cellar/emacs/24.3 (3909 files, 115M) *
  Built from source with: --cocoa, --srgb
From: https://github.com/Homebrew/homebrew/commits/master/Library/Formula/emacs.rb
==> Dependencies
Build: pkg-config ✔
Optional: gnutls ✘
==> Options
--cocoa
    Build a Cocoa version of emacs
--japanese
    Patch for Japanese input methods
--keep-ctags
    Don't remove the ctags executable that emacs provides
--srgb
    Enable sRGB colors in the Cocoa version of emacs
--use-git-head
    Use Savannah (faster) git mirror for HEAD builds
--with-gnutls
    Build with gnutls support
--with-x
    Include X11 support
--HEAD
    install HEAD version
==> Caveats
.app bundles were installed.
Run `brew linkapps` to symlink these to /Applications.
~$ 
0

I disabled all settings till it worked again and tracked down the problem to where I wrongfully set the DYLD_LIBRARY_PATH when emacs is not launched from the command line. Apparently, this influences launching Skim...

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.