I am using a D-Link DWA 123 150n USB wireless adapter to connect to the wireless network. Attached is a screenshot of my ping. The address i am pinging to doesn't really matter because no matter where i ping, the result is the same.

Here is a link to a screenshot of what is going on. http://postimg.org/image/wi4xfdqa5/

I have tried a whole bunch of things but have finally realized that it has something to do with ... something on my PC's side. When using a wired connection via LAN it works fine and I get stable pings. I have tried pinging the connection using another laptop and the ping is fine as well. There must be something happening in the background. The sudden spike doesn't always happen and it seems to suddenly fix itself at times but it will go on for hours usually. The interval between spikes is not always consistent either.

  • So you're looking to find out why you get these really high ping times? You might want to make your question a bit less open-ended. Is it affecting your performance, or is it only on pings that you notice this issue? From your screenshot it looks like you are running windows 7. Maybe you could also share some details about the wireless router/ AP that you are connected to? How far away you are from it? Whether you have any high-usage USB devices connected to the same root hub? What you've done to troubleshoot it so far? Check out some other posts on superuser and you'll get the idea. – G Koe Mar 16 '14 at 5:13
  • Yes, I apologize for the lack of details as I am not familiar with networking -- The pings are affecting my streaming, downloading, and online gaming. What i have done is run the ping on my laptop over wifi as well and there seems to be no problem. I get a steady ping. I have tried switching routers and the problem still persists. I have tried to figure out a pattern for the times when the issue comes up but as far as I can tell, it is completely random. To troubleshoot I do the usual "switch the modem on and off" and "reset the wireless adapter". This actually works sometimes but not often – user3237314 Mar 18 '14 at 2:32

I've got the same problem and here is what I found as fix on another forum:

in your windows cmd, type in

netsh wlan show settings

and one of the last things might say

Auto configuration logic is enabled on interface "Wireless Network Connection"

if that's the case, then type in

netsh wlan set autoconfig enabled=no interface="Wireless Network Connection"

It should respond with

Auto configuration has been disabled on interface "Wireless Network Connection".

If it doesn't, then you might have mistyped your interface=" part. Check in your adapter settings, you might have Wireless Network Connection 2 or 3 etc.

This will definitely stop your wireless card from searching for nearby networks and updating your signal quality when you're not asking it to- which is what is causing the spikes.

You will need to turn it back on if you disconnect or need to be able to find nearby networks again. To do so change disabled to enabled from the earlier command or copy pasta

netsh wlan set autoconfig enabled=yes interface="Wireless Network Connection"

Good Luck!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.