Trying to boot Windows 8.1 or Windows server 2012, either a previously installed VM or booting from CS/ISO on virtualbox gives Error code: 0x000000C4.


This solution fixed the problem for me:


You need to set a parameter in virtualbox to enable a certain CPU instruction. [vmname] should be replaced with the name of the affected VM without square brackets.


"c:\Program Files\Oracle\VirtualBox\VBoxManage.exe" setextradata [vmname] VBoxInternal/CPUM/CMPXCHG16B 1

Mac, Linux:

VBoxManage setextradata [vmname] VBoxInternal/CPUM/CMPXCHG16B 1
| improve this answer | |
  • 3
    Command VBoxManage setextradata [vmname] VBoxInternal/CPUM/CMPXCHG16B 1 works also under Ubuntu (14.04), vbox 4.2.26 – reallynice Aug 28 '14 at 9:55

I also had the same issue, and it's also possible to set CMPXCHG16B globally:

"C:\Program Files\Oracle\VirtualBox\VBoxManage" setextradata global VBoxInternal/CPUM/CMPXCHG16B 1

However I also had to go into the BIOS and change the Memory Protection setting from Disabled to Enabled before the issue went away.

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.