I'm trying out Mercurial for the first time but am having problems doing a push/pull/clone with a remote server (in this case it's codebasehq.com) when using TortoiseHg.

Here are some steps to reproduce:

  1. Download and install TortoiseHg
  2. Go to directory where I want my repository
  3. Right click -> TortoiseHg -> Clone
  4. Enter ssh://hg@codebasehq.com/accountname/projectname/repositoryshortcode.hg as the source path
  5. Click Clone

Once I've clicked Clone it pops up a error dialogue

"PuTTY Fatal Error" "Disconnected: No supported authentication methods available."

and when returning to the clone dialogue this error is shown:

running ""C:\Program Files\TortoiseHg\TortoisePlink.exe" -ssh -2 hg@codebasehq.com "hg -R accountname/projectname/repositoryshortcode.hg serve --stdio"" no suitable response from remote hg

[command interrupted]

What do I need to do to prevent this error and successfully interact with the remote repository?

3 Answers 3


Clocked it. I needed to create an ssh-key pair. To do this I opened puttygen.exe and generated a key. Then I run pageant.exe and added the generated key to its list. The final stage was to log in to codebasehq and add the text of the key (from the box in puttygen labelled 'Public key for pasting...') to my profile.

Hope this helps someone.

(I'm going to accept my own answer but if someone can come up with a more concise answer I'll happily accept yours instead)

  • Pageant.exe not pagaent.exe :D
    – user95570
    Aug 25, 2011 at 23:27
  • 1
    just pointing out for those not familiar with PAGEANT.exe - after you start it, you will find a computer icon with a hat (yes, indeed) in the tray. Rightclick - add key. This solved my issues with bitbucket as well
    – Toskan
    Nov 14, 2013 at 19:43

I just had the same error message. But in my case, the problem was an outdated Pageant version that came with TortoiseHg.

A great trick to debug the "No supported authentication methods available" error message is to add -v in mercurial.ini

\# Generated by TortoiseHg settings dialog
username = name <name@email.com>
ssh = "TortoisePlink.exe" -ssh -2 -batch -C -v


remote: Pageant is running. Requesting keys.
remote: Failed to get reply from Pageant
remote: Using username "hg".
remote: Disconnected: No supported authentication methods available (server sent: publickey)
no suitable response from remote hg

Also see:



  • 1
    Possibly-related bug: bitbucket.org/tortoisehg/thg/issue/1760/… Mar 26, 2012 at 22:40
  • Thank you! I tried everything else and finally upgrading from 0.60 to 0.62 fixed it. Bless you sir. Apr 7, 2012 at 0:43
  • Thank you. In my case, i installed a newer version of TortoiseGIT (which had a newer version of pageant.exe). I had to exit the older version (which was running and was part of git extensions for visual studio) and tried again! Worked like a charm. Thanks again for the tip! Sep 17, 2013 at 9:07

I had the same problem. I use Git Extensions on windows. My solution was a little different tough. Instead of using the ssh repo, I used the http URL.

Something Like: https://{user}@bitbucket.org/{owner}/{name}.git

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.