0

I have recently performed a fresh install of Snow Leopard on a MacBook. Everything seems to be working well with one exception - the hard drive icon does not open a window when clicked, and appears 'greyed out' in the Finder:

alt text

I have checked the permissions of the drive and they seem to be in order. Furthermore, I am pretty sure that I'm logged in as a user with admin rights:

alt text

Any ideas what the problem could be?

1

A few ideas to start with:

  1. If you haven't already, restart the computer.
  2. Unmount and remount the volume in Disk Utility.
  3. Repair the volume in Disk Utility
  4. Check /Volumes to see if it is mounted at all. You can get to /Volumes using the Go to Folder… dialog (⇧⌘G in the Finder).
  5. Check the system log just after starting up the computer to see if any errors occur mounting the volume.

This is not the startup disk, right? Is it a partition on the same physical disk?

2
  • The restart fixed it. – teabot Nov 23 '09 at 14:01
  • Great to hear. A volume is usually greyed-out in Snow Leopard if it's being ejected. It looks like something tried to eject exa and for whatever reason the eject didn't complete. – s4y Nov 24 '09 at 4:28
1

Check in Preference Panes/Accounts to see if you do have admin privledges and change your password to see if you're able to.

Boot from your DVD and run Disk Utility and Repair Permissions. (Select your language if asked, and after the Installer window appears, open Disk Utility from the menu bar.)

0

See this answer at AskDifferent: https://apple.stackexchange.com/a/101083

The partition is hidden. Make it visible again:

sudo chflags nohidden /Volumes/*MY_PARTITION*

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.