I briefly installed Chrome on OSX Mavericks. I decided to delete Chrome.

My user account "manages" web browsing for me, so only websites authorised by me are allowed access. I do this so I can keep track of which websites software installed on my Mac are really accessing.

To my surprise, "Google Software Update" seems to be installed on my Mac, and is trying to connect to google analytics. I deleted Chrome, so I don't see why this should be installed.

Using Finder, I can't find any "Google" software using the search feature.

How can I remove this ?

  • 4
    More seriously, according to this page, the command to do it is sudo /Library/Google/GoogleSoftwareUpdate/GoogleSoftwareUpdate.bundle/Contents/Resources/GoogleSoftwareUpdateAgent.app/Contents/Resources/install.py --uninstall – kinokijuf Mar 19 '14 at 6:47
  • I have the directory ~/Library/Google/GoogleSoftwareUpdate/GoogleSoftwareUpdate.bundle/Contents/Resour‌​ces/GoogleSoftwareUpdateAgent.app/Contents/Resources/, but it doesn't contain install.py. What should I do? – ma11hew28 Nov 12 '14 at 4:08
  • 1
    @MattDiPasquale: checkmy answer below, I have stated what is the new command. – Henrique de Sousa Jan 27 '15 at 0:26
  • This seems to be very version-specific, so people answering or commenting on this, please state whether your comment applies to 10.8, 10.9 or 10.10 – smci Sep 14 '16 at 17:32
  • According to the Google Updater for the Mac FAQs page, “Google Updater for Mac has been retired”. I think that means after you uninstall it once, it won’t be reinstalled – you don’t have to lock folders or anything to prevent it from coming back. – Rory O'Kane Apr 6 '19 at 6:51

The new command is now the following:

sudo /Library/Google/GoogleSoftwareUpdate/GoogleSoftwareUpdate.bundle/Contents/Resources/GoogleSoftwareUpdateAgent.app/Contents/Resources/install.py --nuke

This was an older command:

sudo ~/Library/Google/GoogleSoftwareUpdate/GoogleSoftwareUpdate.bundle/Contents/Resour‌​ces/GoogleSoftwareUpdateAgent.app/Contents/Resources/ksinstall --uninstall

In the older command above, you may prefer to replace the --uninstall with the --nuke option. The former supposedly leaves some files, while the latter removes them.

Alternatively, Google Software Update might be installed within /Library/, in which case it can be removed with:

sudo /Library/Google/GoogleSoftwareUpdate/GoogleSoftwareUpdate.bundle/Contents/Resources/GoogleSoftwareUpdateAgent.app/Contents/Resources/ksinstall --uninstall

Also try:

sudo /Library/Google/GoogleSoftwareUpdate/GoogleSoftwareUpdate.bundle/Contents/Helpers/ksinstall --uninstall
| improve this answer | |
  • 1
    Why the downvote? I have reinstalled Yosemite 10.10.2 last week and I still haven't redone the process. So now I have just tried the uninstall process and it's still working!! So please, try again, this time type the command instead of copy/pasting it, and upvote again, because it IS working! I'm using Chrome 41, and to test it, just do "About Chrome" and update process will fail. – Henrique de Sousa Mar 24 '15 at 22:49
  • 1
    This is correct for Mac OSX 10.11.2. Use the --nuke option instead of --install to get rid of everything. Then remove the ~/Library/Google directory. – Mo'in Jan 25 '16 at 18:58
  • 1
    I woke up today and my Mac was shutdown. This was the second time in a few days. The last thing in the system log was GoogleSoftwareUpdate. So I did: /Library/Google/GoogleSoftwareUpdate/GoogleSoftwareUpdate.bundle/Contents/Resources/GoogleSoftwareUpdateAgent.app/Contents/Resources/ksinstall --nuke. I'm on 10.12 (Sierra). I shutdown and rebooted. Things appear fine. – pedz Jan 17 '17 at 14:41
  • 5
    Run touch ~/Library/Google/GoogleSoftwareUpdate && sudo chown -R root:wheel ~/Library/Google after running the --nuke command above. This replaces the updater directory with a file and locks your user out of it, which will now prevent Chrome bringing it back. The chown might be overkill, but it does give good assurance nothing is messing with that file. – davidjb Apr 11 '17 at 0:34
  • 1
    @beroe I don't think there's a definitive answer; which command/options to use seems to be a moving target that depends on the version of various components and the whim of google. – jhfrontz Mar 7 '19 at 15:22

On their official help page, they only mention disabling the checks:

To disable Google Software Update from checking for updates, execute the following in the Terminal application:

$ defaults write com.google.Keystone.Agent checkInterval 0
| improve this answer | |
  • This doesn't disabled the auto update of Chrome on my system. Would be nice to find another working solution without uninstalling update service – Karl Adler May 5 '15 at 8:54
  • 1
    If you go to “About Google Chrome” info window it will still check then, but it shouldn't run automatically anymore in the background. – lkraider May 5 '15 at 16:58
  • 2
    but it does. Have you tested on OSX 10.10? – Karl Adler May 5 '15 at 20:05
  • No, I am running 10.9 only. – lkraider May 6 '15 at 15:21
  • People commenting here, please state whether your comment applies to 10.8, 10.9 or 10.10 – smci Sep 14 '16 at 17:27

Success on a Mac Sept 29, 2017:

The "official" Google-given method given to stop the Google Software Update is this, but it doesn't always work. The updater sometimes, on some systems, finds a way to reset itself and update anyway. In Terminal: defaults write com.google.Keystone.Agent checkInterval 0

The most foolproof method is to deny Chrome the permissions it needs to install the update software and run it. Empty these directories: /Library/Google/GoogleSoftwareUpdate/ ~/Library/Google/GoogleSoftwareUpdate/

Then change the permissions on both folders named GoogleSoftwareUpdate so that there's no owner and no read/write/execute permissions.

In terminal:

cd /Library/Google/
sudo chown nobody:nogroup GoogleSoftwareUpdate
sudo chmod 000 GoogleSoftwareUpdate
cd ~/Library/Google/
sudo chown nobody:nogroup GoogleSoftwareUpdate
sudo chmod 000 GoogleSoftwareUpdate

If you want to be double-certain, then do the same for the folder Google one level up.

cd /Library/
sudo chown nobody:nogroup Google
sudo chmod 000 Google
cd ~/Library/
sudo chown nobody:nogroup Google
sudo chmod 000 Google

I did this immediately after installing the Chrome version I need for my machine, and it worked perfectly. Now when I check About Google Chrome it gives me the error "Update failed (error: 10)" It's still trying to update, but it can't do it any more.

| improve this answer | |

Use --help to see the various ksinstall options, i.e. ksinstall --help

cd ~/Library/Google/GoogleSoftwareUpdate/GoogleSoftwareUpdate.bundle/Contents/Resour‌​ces/GoogleSoftwareUpdateAgent.app/Contents/Resources/

ksinstall --help

[--install=PKG]     Install keystone using PKG as the source.
[--uninstall]       Remove Keystone program files but do NOT delete
                    the ticket store.
[--nuke]            Remove Keystone and all tickets.
[--interval=N]      Set installed agent to wake up every N seconds.
[--lockdown]        Prevent Keystone from ever uninstalling itself.
[--force]           Perform operation even if it is a downgrade.
| improve this answer | |
  • 1
    This doesn't actually answer the question. – DavidPostill May 30 '16 at 12:06
  • Or /Library/Google/GoogleSoftwareUpdate/GoogleSoftwareUpdate.bundle/Contents/REsources/ksinstall --help for those with GSU installed system-wide. – jhfrontz Feb 14 '17 at 11:27

In my Mac OS X 10.9.5 ksinstall resides in the main library. The commend is thus:

sudo /Library/Google/GoogleSoftwareUpdate/GoogleSoftwareUpdate.bundle/Contents/Resources/ksinstall --nuke
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.