I have a problem when accessing my site in Internet Explorer 11.

Requests are Aborted about half the time, within <1ms when I try to load a page too soon after a previous request to the same site (not necessarily the same page).


  • If I click on a link within a short while (1 min?) after loading a page. I get an error page

This page can’t be displayed
Make sure the web address https://my.domain.com is correct

  • The Developer Tools show (Aborted) in the Result column.
  • If I try to reload the page with F5 or by clicking in the reload icon in the address bar, the page will load correctly.
  • If I reload the page using a link to itself (e.g. clicking Home on the home page) the Developer Tools will show navigate or click in the Initiator column, the request will be aborted if it's too soon after the last request.
  • I can use F5 (Initiator/refresh) as many times as I like without waiting and the page will load every time. According to the Developer Tools, the request is first aborted immediately and then retried with Initiator being blank on the second (successful) attempt.
  • I don't have the same problem on other machines with IE 11

I'm not sure if it matters, but I'm accessing the site via https://

I have no problems in any other browser I've tried. Firefox, Safari, Chrome, Opera.

When I access the webapp on my localhost development copy, I have no problems in IE.

The webapp is hosted on a sub-domain, on a different server to the main domain.

I've tried things like comparing my DNS set-up and Internet Settings to the other machines where this problem doesn't occur.

Has anyone come across a similar issue/fix?

  • did you find the solution?
    Feb 18, 2021 at 23:27
  • 1
    @YASHDAVE far as I remember, this happened only on my development machine (other users were not affected) and clearing the browser cache solved the issue, see my answer below
    – Loopo
    Feb 25, 2021 at 13:45

1 Answer 1


I finally had the idea of clearing the browser history.

This happened by coincidence as I was working on some .css changes at the time and those changes didn't seem to get reflected when reloading the page.

I cleared Temporary Internet files, Cookies and History. I assume clearing Temporary Internet files is what cured the problem.

  • 2
    Doesn't work for me....
    – pilau
    Oct 25, 2015 at 14:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.