When I log into windows, my system maps a few drives from our server's shares. I have a backup script that I want to run and it maps a few more drives just for the script and then unmaps them when done.

I'm running the following to map: net use z: "\server\share1" /user:myuser password

It then says System error 1219 has occurred. Multiple connections to a server or shared resource by the same user, using more than one user name, are not allowed. etc

Thing is, I'm using the same user for everything. Why would it give me this error and how do I fix this? I'm using Windows Server 2008 R2 with this script.

  • Try using net use without parameters, see if it lists any other connection to that server you might need to delete first – kenkh Mar 19 '14 at 16:38
  • net use reports back all of my shares with all saying status is ok – user277244 Mar 19 '14 at 16:39
  • 1
    I would do a net use /delete * and re-run the script to make sure that no other shares were mapped with another user. – shinjijai Mar 19 '14 at 16:45
  • Error 1219 is "Multiple connections to a server or shared resource by the same user, using more than one user name, are not allowed. Disconnect all previous connections to the server or shared resource and try again." Just FYI. – Angstrom Mar 21 '14 at 22:49

Since at least Windows NT 4.0, only a single set of user credentials can be used for a single server name, where the server name is determined when mapping the resource (e.g. the server in \server\share).

If using the same set of user credentials is acceptable, the additional server share can be successfully mapped by not specifying the user name or password. So, in your case, performing the first net use with the /user and password arguments and the second without should work.

If using the same set of credentials is not acceptable (i.e. you must map two resources from the same server using different user credentials), you can work around the problem by creating and using a DNS alias for the server, or using the server's IP address.

See the following for additional details:

  • http://answers.microsoft.com/en-us/windows/forum/windows_vista-networking/the-network-folder-specified-is-currently-mapped/928f6313-fe2c-4d2d-a247-152ec022e062
  • http://support.microsoft.com/kb/938120
    • Using the digital IP address worked for me, thanks. To go back to using own credentials, I deleted the /user: parameter altogether (its spelling using the domain prefix or the email-like suffix seems to matter). – eel ghEEz May 28 at 15:20

    Got it. A quick reboot fixed this issue. Thanks

    • Glad you got it :) – kenkh Mar 19 '14 at 16:45

    Your Answer

    By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

    Not the answer you're looking for? Browse other questions tagged or ask your own question.