7

How can I completely disable the scroll wheel on my mouse on a Windows 7 system? This would be system wide not just for a single application.

  • This question specifically asks for Windows 7 and the other (duplicate) question specifically asks for Vista, so it's not obvious that the other answer is applicable. – Steve Eynon Jul 15 '15 at 22:53
10

I am going on the assumption that you want to disable scrolling. If not, please clarify your question.

For some reason, Windows wont let you set the vertical or horizontal scrolling to zero for the mouse wheel in the Control Panel. However, you can manually set them to 0 in the registry.

Open the Registry Editor by clicking Start and typing regedit and hit enter.

Navigate to HKEY_CURRENT_USER\Control Panel\Desktop and set WheelScrollChars and WheelScrollLines to 0.

A reboot is necessary for this to take affect.

This will disable scrolling, not the button itself.

PS: If you open the Mouse setting in the Control Panel, it will reset those settings back to 3. Just FYI.

| improve this answer | |
  • Thanks. How can I navigate to HKEY_CURRENT_USER\Control Panel\Desktop? There's no address bar – Colonel Panic Mar 20 '14 at 15:26
  • @ColonelPanic | Stick regedit.exe in your Windows start search bar and load the .exe which shows. You find what you need in there. – Matthew Williams Mar 20 '14 at 15:29
  • @ColonelPanic - You have to use the registry editor. – Ramhound Mar 20 '14 at 15:32
0

A different approach might be to open up the mouse and remove the scroll wheel.

| improve this answer | |
  • 2
    When you can do it in software, no need to corrupt the hardware... – shgnInc Feb 23 '16 at 14:18
  • 1
    my mouse has the board forked up somehow and it randomly scrolls the mouse even without the scroll wheel, so not an option – user1916182 Oct 27 '17 at 9:10
  • 1
    also you would lose the ability to mid-click – user1916182 Oct 27 '17 at 9:10
  • Removing the wheel from an apple magic mouse? That's not possible. And even if: I don't want to loose the scrolling from the host OS. Only VM I access via Remote Deskop has annoying behaviour. – Martin Dec 18 '18 at 14:44

Not the answer you're looking for? Browse other questions tagged or ask your own question.