For some reason I decided it would be a good idea to apt-get remove cmake from my ubuntu 12.04 distro and then put it back, but when I do sudo apt-get install cmake I get the following error:

The following packages have unmet dependencies:
 cmake : Depends: cmake-data (= 2.8.7-0ubuntu5) but is to be installed
E: Unable to correct problems, you have held broken packages.

I have also tried to install cmake according to this guide, which appeared to have completed successfully, but still no cmake. I get

bash: /usr/bin/cmake: No such file or directory

What would cause this issue and how can I fix it?

  • did you create the /usr/bin/cmake folder and then try it?
    – Malachi
    Mar 20, 2014 at 23:44

1 Answer 1


The link provided in the question sets the build directory in the configure to /opt/cmake, and as noted in that discussion, cmake can be ran as


You can copy the /opt/cmake/bin/cmake to the /bin/ directory, or add the /opt/cmake/bin/ directory to your $PATH environment variable to be able to use cmake as


As for the dependency issue, it's currently still a mystery.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.