I have an ASUS Maximus V Extreme motherboard which has onboard video. There is an Asus GeForce GTX 670 in PCIe slot 1.

In the BIOS, I have PCIe selected as the preferred GPU. I've tried disabling Fast Boot and other items to attempt to get the PCIe display to work during POST. I've also updated the BIOS to the latest version available on ASUS' support site.

With the HDMI display plugged into the onboard video, I can see the POST and everything is fine. With the HDMI display plugged into the PCIe GPU, I have a blank screen until the point in which Windows starts to initialize and then everything is fine.

Is there a setting somewhere that I'm missing?

The problem is, I dual boot to Ubuntu and I'm forced to manually switch the HDMI cable to select things during POST or to enter BIOS. Not very convenient.

Any help would be greatly appreciated.


In my experience, the only way to resolve this is by disabling the on-board video adaptor and to not even have a video cable connected to it. This way the bios will fail over to the PCIe adaptor for post and initialize it as display #1. This is a pretty common issue with PCs with on-board video display.

  • I would love to but I can't seem to find a way to fully disable the onboard video card in the BIOS. – Travis Vocino Mar 21 '14 at 2:04
  • The only option I can find in the manual that might disable it is the iGPU Multi-Monitor option (chapter 3 page 29). – MaQleod Mar 21 '14 at 2:31
  • What happens when you try booting it with no cable connected to the motherboard. Just the PCIe card connected? Also try disabling "Lucid Virtu" See this Asus support thread: rog.asus.com/forum/… – Bryan C. Mar 21 '14 at 2:56
  • @MaQleod I currently do have iGPU Multi-Monitor disabled. – Travis Vocino Mar 22 '14 at 2:02
  • 1
    @TravisVocino Ok, I did some more digging. I've found some info in the ASUS forums that indicates that that you may actually not be able to completely disable that adapter but I also find discussions on where you can. :( --- You might want to go to Asus tech support for further information though as I find it surprising that this could really be the case. Sorry I couldn't help more on this. Can you post the exact model number of your board and I'd be glad to pull down the tech manual to see if there's anything in it. – Bryan C. Mar 23 '14 at 0:21

I solved this issue by switching CSM in the BIOS from Auto to Enabled and then specifically changing the PCIe setting to Legacy First.

I'm assuming my video card does not have UEFI support. I'm planning on upgrading the video card next week so I'll be able to test another card and see if I can move back to setting CSM to Disabled.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.