7

I find no way to unset or remove default keyboard shortcuts in Sublime Text 3. The default settings are not editable anymore, so I have this in there:

{ "keys": ["f2"], "command": "next_bookmark" },

I have tried "command": "unbound" in user settings but it just unbinds the "next_bookmark" command from it, the key is still intercepted and captured by ST3. I have some important global shortcuts which I'm simply unable to use without switching to another window first.

Is there any way of solving this?

  • copy the default keyboard shortcut settings into the user keyboard settings and edit there. – Mrsonord Mar 21 '14 at 13:11
5

You can override the default package. To do this easily, you can use https://github.com/skuroda/PackageResourceViewer. Open the Default/Default (your os).sublime-keymap file, make your edits, then save the file. The plugin will place it in the proper location to override the default bundled file.

| improve this answer | |
  • A word of comment: after doing so, the PackageResourceView will put the extracted package in a writable status. To restore the default keymap settings back into a read-only status, use chmod u-w Default (OSX).sublime-keymap, for example (on Mac). – aafulei Aug 6 '19 at 2:07
  • Note: this also works with shortcuts added by other packages in the same way you can override their sublime-keymap files. – tutuDajuju May 9 at 7:15
1

To insert Unicode in Ubuntu 18.04 I normally use ctrl+shift+u, but that fails in ST3.

I can't find any method that works on ST3 3175 under Ubuntu. I tried mapping it to "pass", to false, and using Package Resource Viewer to edit file .../Packages/Keymaps/Default (Linux).sublime-keymap.

There is a package (Unicode Character Insert) that says it will insert unicode characters but it only puts up a small chart of characters it knows about.

| improve this answer | |
0

I know it's very old, but I found the solution that worked for me with no packages installed here.

All you have to do is use the same default setting in the user defined part with replacing the command with "pass".

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.