1

This odd behavior just started happening on my Windows 7-based HTPC in the last couple of weeks. Whenever I'm watching video in my web browser (both Firefox and Chrome), the sleep setting of the PC kicks in and thus it goes to sleep. It never used to do this, and when I look at the Power Settings, I have the following set:

Power Options -> Advanced Settings -> Multimedia settings -> When sharing media -> "Prevent idling to sleep"

as per other sites I've come across trying to solve the same problem. However, this isn't helping matters. Interestingly, when I'm watching a recorded television show via Windows Media Center, the PC stays awake the entire time.

Is there another setting somewhere that I need to ensure is set? The only thing that changed between when this didn't happen and now is that I moved to a new home. And I can't imagine how that would have somehow triggered this - I didn't change any settings on the PC before this started happening.

Update/further notes:

I did a test on my desktop PC with nothing else running other than my Firefox web browser, and it kept streaming a television show past my sleep timer without ever actually going to sleep, just as my HTPC used to until recently. Also, and perhaps more telling, my HTPC never turns off the display before going to sleep, and that has a shorter time setting than the system sleep setting. So, the PC is properly ignoring the display turn off setting when streaming web video, but not the sleep setting. Very weird.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.