1

I tried to install Git (from source) on Debian 7.4, but the installation fails with the following message:

Writing perl.mak for Git  
Writing MYMETA.yml  
    * new perl-specific parameters  
    GEN git-add--interactive   
sed: -e expression #4, char 49: unknown option to `s'  
make: *** [git-add--interactive] Error 1  

My sed version is 4.2.1, make is 3.81. I have no idea what to do now, i tried with the sources of Git 1.9.1, 1.9.0 and 1.8.5.

Any ideas what else i can try?

2

My version of the sed it also: GNU sed version 4.2.1. Several days ago I update my version of the Git without any problem. But I on ElementaryOS.

For install last release try to run below commands:

sudo apt-get install python-software-properties
sudo add-apt-repository ppa:git-core/ppa
sudo apt-get update
sudo apt-get install git

And then you should have like this:

$ git --version 
git version 2.0.1
| improve this answer | |
0

Is there something you are trying to accomplish when installing from the source, or could you simply use the package install apt-get to do it for you.

apt-get install git
| improve this answer | |
  • The package version in the default repositories of Debian 7 is Git 1.7..., which is quite old. However, i managed to include the wheezy-backports repositories, they have Git 1.8.5.3, which is ok for me. – dunni Mar 21 '14 at 23:17
  • Oh ok, i see. There was probably a reason why its still at an old version. – user2494817 Mar 21 '14 at 23:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.