-1

following setup:

A remote linux PC with a wavecom gprs modem tries to connect to the orange romania gprs network via pppd and chat

We use this setup with different providers for a few hundred devices and had never issues in needing to reconfigure pppd options to be able to connect to the GPRS Provider.

I have access to that device via VPN so i can change config options on the fly (at least for now)

The chatscript itselfs seems to connect correctly .

Here the cutted logs:

AT+COPS?
+COPS: 0,0,"orange"

OK
AT+CGREG=1
OK

+CGREG: 0
AT+CGATT=1
OK

+CGREG: 2

+CGREG: 1
AT+CSQ
+CSQ: 24,0

OK
AT+CGAUTO=1
OK
at+cgdcont=1,"IP","internet"
OK
AT+CGACT=1,1
OK
AT+CGDATA=1
CONNECT
Serial connection established.
using channel 11
Using interface ppp0
Connect: ppp0 <--> /dev/gsmmodem
rcvd [LCP ConfReq id=0x1 <mru 1500> <asyncmap 0x0> <pcomp> <accomp> <auth pap>]
sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0x7e7f80ba> <pcomp> <accomp>]
sent [LCP ConfRej id=0x1 <auth pap>]
rcvd [LCP ConfRej id=0x1 <magic 0x7e7f80ba>]
sent [LCP ConfReq id=0x2 <asyncmap 0x0> <pcomp> <accomp>]
rcvd [LCP ConfReq id=0x2 <mru 1500> <asyncmap 0x0> <pcomp> <accomp>]
sent [LCP ConfAck id=0x2 <mru 1500> <asyncmap 0x0> <pcomp> <accomp>]
rcvd [LCP ConfAck id=0x2 <asyncmap 0x0> <pcomp> <accomp>]
sent [IPCP ConfReq id=0x1 <addr 192.168.10.1> <ms-dns1 0.0.0.0> <ms-dns3 0.0.0.0>]
sent [CCP ConfReq id=0x1 <deflate 15> <deflate(old#) 15> <bsd v1 15>]
rcvd [LCP TermReq id=0x3]
LCP terminated by peer
sent [LCP TermAck id=0x3]
Connection terminated.

here are the config options we currently use:

defaultroute
noipdefault
modem
/dev/gsmmodem
115200  
crtscts
persist
maxfail 1
debug
nodetach
novj
asyncmap 0
name " "
 usepeerdns

passive

http://pptpclient.sourceforge.net/howto-diagnosis.phtml#debug and http://www.tldp.org/HOWTO/PPP-HOWTO/options.html for some examples i did find on the subject and what i tried to change.

changing or removing the command line options MRU/MTU did not solve the issue, but only changed the response i got for the LCP ConfReq

/usr/sbin/pppd dump mru 1500 logfd 2 nodetach ipcp-accept-local ipcp-accept-remote connect "/usr/sbin/chat -v -f /etc/ppp/pppscript"

what i do find strange is the "conf_rej" auth pap part. if someone could point me to a direction where to look or what option i did need to fix i would be thankfully.

EDIT: In response to Michael Hampton comment i let the details of the sim contract be checked by my client:

It is a Prepaid card, but there is still enough Cash loaded on it , the contract has an unlimited GPRS traffic enabled, the simcard is activated (i just verified this with the client). The SimCard is working on an USB-UMTS Modem sticked to a laptop so in my opinion this rules out any issue with the Simcard and/or the provider connection itself.

Regards

3
  • The other end tore down the connection. Did someone forget to pay the bill? Mar 21, 2014 at 11:53
  • this card is only 2-3 days old for all i know, i will check with my client about this (usually for an installation like this our client will just buy a new one) but as this is a temporary installation this might actually be a prepaid card running out of cash. will report the info later. Mar 21, 2014 at 12:12
  • it is a prepaid card, but there is still enough Cash loaded on it , the contract has an unlimited GPRS traffic enabled, the simcard is activated (i just verified this with the client) Mar 21, 2014 at 13:13

2 Answers 2

0

the reason for this issue: my pap-secret file was somehow not loaded. i was not able to fix the reading of the pap-secret, but adding the options user=xxx and pass=xxx to the file options did solve this issue

0

I had a similar issue which was due to ofono , in ofonod roaming is disabled by default, I stopped ofono service then everything works fine.

https://github.com/intgr/ofono/blob/master/test/set-roaming-allowed

2
  • 1
    Consider being a little more specific with your detail and adding some reference and proof supporting what you state Sep 8, 2017 at 14:48
  • additionally it would be nice to have not a python script depending on dbus for changing the roaming setting but instead giving the AT command to switch this. Sep 11, 2017 at 7:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.