0

Here is a picture of the file I want to open, and the program I want to open it with:

one file extension (.atb) and one jar file picture

  1. If I just click the jar file, it opens my program smoothly (I made that Java program myself), no questions asked.

  2. If I click the file and choose the program in the picture as my default program, it says this:

    picture of message

  3. If I do all this with .txt as the file extension it says the same and still doesn't work.

  4. If I do all this in Windows 7 with the same setup, it all works fine.

I also checked my event logs when this occurs and this pops up as a keyword "Audit Success" with the text:

An attempt was made to query the existence of a blank password for an account.

Do you have any idea what might cause this?

  • What filetype is it? What does it execute and where is the source for your jar? – M.Bennett Mar 23 '14 at 0:51
  • I think java or the file you are opening might be infected... See this Microsoft technet post on the error message. – PlasmaPower Mar 23 '14 at 0:51
  • @PlasmaPower no, i made the file my self, and i made the program (.jar file) my self. The ONLY thing the file contains is that i made a .txt document, wrote "lols" and saved it as a .atb file extension. – Ploug Mar 23 '14 at 0:57
  • @M.Bennet it's a .atb filetype, again only contains the word "lols". It's for me to use for my own program, and again it works in windows 7. The source for my .jar and the source for my file is both on the desktop, the file doesnt execute anything, my program is supposed to open it, and then the program will handle what it needs to handle it self, the problem is that the program won't even be opened so it could be able to do this, eventhough windows 7 allows the program to be opened. – Ploug Mar 23 '14 at 0:58
  • on your windows 7 machine you probably associated the atb filetype to notepad or similar, whereas your windows 8 machine doesn't have a standard application to launch the file with. – M.Bennett Mar 23 '14 at 1:00
1

This can happen due to a number of reasons, so go by trial and error for the following cases:

• Is the File to be executed empty? Check the Filesize...

• Are you trying to run a 64-Bit app on a 32-Bit Version of your OS?

and lastly...

Is JDK 7 installed and is your path set? Run Ctrl + R and type cmd hit Enter and type path and Enter again. If your Java Bin Directory is not in this string then that is your Problem.

  • 1 -> no, it contains the word "lols" and so it makes sense the file size is 4 bytes. 2 > No my OS is 64 bit. 3 ->.. hmm i get this? picture – Ploug Mar 23 '14 at 19:34
  • A little late, but your Path is not set according to your screenshot...Post the solution if you've solved it ;) – M.Bennett May 4 '15 at 17:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.