7

So my brother has a Asus laptop(old) which came with Vista Ult. When Win 7 was released i installed it and everything worked fine (all the drivers). Then my brother tried dual booting it Win7 and Ubuntu (might have been 10.04 or something similar). After the install everything was working fine in Ubuntu, but when he rebooted into Win 7 there was no sound coming out of the speakers (earphones and headset were working fine). In the windows sound 'Playback' settings the speakers would show up set as default, the audio levels would jump when you played a video or sound file, but no actual sound came out of the speakers.

I tried updating drivers, clean(format HDD) Win 7 install with and without the original drivers just the automatic ones that windows picked up on, on separate occasions. After all my attempts sound through the speakers wasn't working in Windows. But when i would load Ubuntu live from USB and sound would work fine.

Later i tried installing Win 8 and the same thing happened, no sound. I even tried installing the original copy of Vista and all the drivers again and the same thing would happen, everything but the speakers would work.

Any ideas to get the speakers working in Windows?

More info 1
-I would would like to add that the bios is up to date and have tried resetting all the bios setting to manufacturer default.
-As i have 2 of the laptops(my brother and I) i have also tried swapping the HDD's and the same result.
-In safe mode the sound icon has an 'X' through it, 'No audio devices are installed'. The troubleshoot results are 'One or more audio service isn't running --- Not fixed'

More info 2
-I actually got the sound working once not sure which OS Win7 i think, by just swapping the OS between Vista and Win7 few times and installing the drivers... But then i tried to do a clean install and speakers stopped working again. I was never able to replicate the results again (not exactly sure what made it work).

4
  • What is the result in safemode? – mok Mar 23 '14 at 4:43
  • I can tell you that the installation of another operating isn't the cause of your sound device not working – Ramhound Mar 23 '14 at 4:50
  • Can you confirm that the sound does not work if you do this sequence? 1) Boot Ubuntu - test sound. 2) Shut down (no reboot, no sleep, no hibernate. shutdown -p). 3) Boot windows and test. – Hennes Nov 16 '14 at 20:59
  • In theory, a linux distr can alter BIOS settings with inb and outb and changing the IRQ can affect the sound device, but this is not something that suppose to happen (it's very unlikely, although possible). – Overmind May 6 '15 at 11:17
15

I have exactly the same problem with my Samsung QX410. After reinstalling Windows, then logging into Fedora, then back into Windows I discovered again the problem which was the cause of reinstalling. Fortunately I found a solution at quora and it works for me: just turn the Windows to sleep and then wake it up (at least the procedure is faster than reinstall or shutdown).

6
  • Works for me. Thanks alot. It's much more faster than reboot. – Thang Nguyen Dec 27 '14 at 6:33
  • lmao, how does this even work. any ideas of whats causing the issue? – Because I'm a noob. Jul 3 '16 at 0:11
  • After digging through many sites and ideas, this simple solution was what worked for me. Thanks a lot! – Mahm00d Dec 29 '16 at 21:25
  • this also fixed my audio glitch like this one – Yibo Yang May 10 '17 at 0:39
  • It's working! I couldn't find any other solution for it. Thanks. – Mehrdad Oct 8 '17 at 16:16
0

Please restart the computer and enter the BIOS setup (generally by pressing the F10 or F2 function keys at the very beginning of the boot process). In the BIOS setup, find the section for integrated devices and enable the integrated audio (On-board audio) and restart the computer.

13
  • Here this the only thing close to what you are talking about oi62.tinypic.com/166lq4o.jpg And it was enabled/unlocked – crbon Mar 23 '14 at 4:59
  • @user2924842: which os are using now? – mok Mar 23 '14 at 5:15
  • I'm using Windows 8 – crbon Mar 23 '14 at 5:16
  • Try this, go into control panel, chose Personalization then clicked the speaker section and chose another set of audio options then tested it. (Maybe you need to update to win8.1) – mok Mar 23 '14 at 5:19
  • I'll try that later on today. Here is the original audio driver readme file pastebin.com/CGbaTvVF There might be something useful there – crbon Mar 23 '14 at 5:29
0

It reminds me of some Realtek troubles I had some years ago. What I remember from that is that the installation of Ubuntu leaves the audio hardware in such a state that Windows can't access it anymore. I think one of these two options solved it:

  • Turn your computer off (really off: unplug the power cord and wait for a minute or two). Reboot to Windows.
  • Start Windows and remove all audio drivers. Turn your computer off (again - really off: unplug the power cord and wait for a minute or two). Restart Windows and reinstall the audio drivers (you can use the "Search for new hardware" feature).

Another recollection I had: check that your wires is plugged in right. With some weird audio rerouting software setup under Windows I had to plug in my speakers jacks to a certain hole (the black one, if I remember correctly), but under Ubuntu, I had to connect them to another hole (the green one, I think). Long story short: make sure you have your jack in the right hole... ;-)

I hope this helps. It's a bit vague, as it is some years ago, but maybe it helps. Please let us know if one of these things provided a solution for you!

1
  • I'm still looking for a solution... Hmm I've tried your suggestion, gave it about 5 minutes without battery power after each shutdown. Still nothing, I'll try again removing the drivers and installing new manually download drivers. I still believe that Ubuntu is the key... If you still have any ideas or suggestions let me know :) @agtoever – crbon Oct 26 '14 at 3:39
0

I have this problem quite often. I am a programmer and a musician. I use Ubuntu for programming and Windows for my music making purposes. It really angers me when this happens, but I HAVE A SIMPLE SOLUTION for this.

  1. Boot into your Ubuntu(whatever Linux Distro you have) and Play a sound file and this should be coming out of your device, whatever it is (Headphones/Speakers).

  2. Now just restart your system while the music still plays on your Ubuntu(Any Linux). I mean don't turn off the music you've been playing, while you restart.

  3. Now the system will reboot and select Windows from the GRUB boot loader.

  4. This will solve it.

The sad thing is, you have to do this every time this happens.

-1

Just shut down the system with speakers on (restarting won't help).

Then select Windows and log in. The speakers now work.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.