4

I just created a Kali 1.0.6 live USB using a tool called "Mac Linux USB Loader" and everything seems fine up until the point where you are supposed to login.
At the login screen I'm greeted with the choice of user "Other" where I have to manually enter at username and password.
The problem is that I have not created a user or set any password, and "root" as user and "toor" as password doesn't work.

EDIT

I reinstalled Kali and got it working, I did it like this:

  1. My friend installed Kali on his USB-drive, using normal install process inside his Linux OS
  2. We plugged his USB into my Macbook and booted from it
  3. I plugged in my USB which I wanted Kali Live on
  4. Using my friend's Kali Live (that we booted into) we opened the terminal and used a command called "dd" which copies everything from one location to another. Done!
6
  • You should have specified a password when you installed the system. Mar 23, 2014 at 21:03
  • @MatthewWilliams Perhaps I should, but there really was no installation since it's a live USB. Mar 23, 2014 at 21:13
  • When you say you have tried default. Did you select "other" and put "root" and "toor"? Mar 23, 2014 at 21:18
  • A small detail: is it a Persistent Live USB? Mar 23, 2014 at 21:41
  • @MatthewWilliams Yes. Mar 24, 2014 at 10:51

5 Answers 5

2

I was having the same problem although a slight difference was I installed in Virtual Box. When ask during the install for a admin/root password I created one. After the install and reboot I was ask for a user/other and password in order to log in. root and toor were not working After several failed tries I finally logged in using root as the user and the password I created during setup. Hope this helps someone.

2

This worked for me:

  1. Select Other user

  2. Use root as the username

  3. Enter the root administrator password you entered during the install.

1
  • I think that OP tried that and didn't work!
    – Davidenko
    Mar 22, 2015 at 19:03
2

Don't Worry...!

STEP 1: Wait till GRUB LOADER and SELECT (RECOVERY MODE) and hit e to EDIT...

STEP 2: Add this line as below -> init=/bin/bash enter image description here

Step 3: Then PRESS Ctrl+X or F10 to BOOT....

Step 4: After booted, TYPE fdisk -l which will display the partitions (the one with the * is root partition) as below:
enter image description here

Step 5: NOW, TYPE mount -o remount,rw /dev/sda1 /

Step 6: NOW, TYPE the passwd command to complete the password reset!!! and (exit or restart your system / in VirtualBox press Host key+R to reset the system)

Now you can log in with your new password!

2
  • But the original poster refers to a "Live USB Kali", probably with no persistence. Each time you reboot, the changes will be deleted. Oct 27, 2015 at 2:33
  • This worked for me after having problems installing from a live usb. I had to copy files to disk and then* install, after which the root toor combination didnt work. Your password reset saved my day.
    – deacs
    Dec 1, 2017 at 18:02
0

Try:

  • root/live
  • user/live

If that doesn't work, it is supposed that you could chroot into your live USB and set a new password with passwd root. Instructions here; the process is not complex, but the mounting of filesystems will probably be long (maybe a few hours).

EDIT: removed suggestion tu use the specified password during installation.
EDIT 2: added new solution: chroot into your Llive USB.

6
  • 1
    The OP already specified he doesn't have the password and the default password as stated in Kali documentation is toor, which the OP has already tried. Mar 23, 2014 at 21:10
  • @sopalajo I tried those without any success. Mar 23, 2014 at 21:18
  • As a (no much chances) possibility: try login from text console (Ctrl+Alt+F1). Mar 23, 2014 at 21:37
  • Upsss... you were right, @MatthewWilliams. I have edited to solve. Mar 23, 2014 at 21:38
  • @SopalajodeArrierez We tried that today, also with no luck Mar 24, 2014 at 10:51
0

After Version 2020.1 the root user is locked. You need to login with
Username: kali
Password: kali
If you need to use the root account, open terminal and run
sudo passwd root
Then you can login as root.

Not the answer you're looking for? Browse other questions tagged or ask your own question.