1

I recently upgraded my emacs to version 24.3.1 on ubuntu (I had a lower 24 version before). I first purged the old version and the installed the current version to get a clean update. Since, then cannot use ispell anymore.

First, I got an error message stating that there is not such function or program. I checked: ispell was installed. I then specified the path to ispell using

setq ispell-program-name. 

Then doing so, I got an error message that permission is denied. So I changed permission (chmod aou+wrx) for the file. Now I get the following error message:

ispell.el exited with code 2. 

This happens whether I evoked ispell-region or ispell-word.

I also installed ispell by hand on my home site-lisp and loaded that fiel, with the same result.

Any suggestions about the meaning of the code would be helpful.

Thanks! Stephan

1

You should not set the path to ispell.el -- instead the path should be to an executable program like aspell -- e.g.:

(setq-default ispell-program-name "/Users/HOME/.0.data/.0.emacs/elpa/bin/aspell")

You do not need to check to see whether ispell.el is installed because it automatically comes with a full version of Emacs. Instead, you need to install something like aspell if you don't already have it installed. You also need to install the language dictionary used by aspell -- e.g., English dictionary. Here is a link you may find helpful regarding installing aspell on Ubuntu:

http://packages.ubuntu.com/lucid/aspell

Think of ispell.el as a front-end, which has useful functions to operate a separately installed spelling program like aspell -- with a separately installed dictionary database (e.g., English).

1
  • Thanks -- that worked! Not sure why I did not have to specify this before. – user3321294 Mar 24 '14 at 13:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.