0

I have a VivoPC VM40B, which works on Windows 8.1. It is a media server, which connected in LAN via WiFi.

I also have a Windows 7 desktop which connects to the LAN via ethernet.

Then, I have Asus Wireless-N300 Router.

VivoPC VM40B (media server) stands in another room. There are 3 walls between the router and media server.

Windows 8 says the WiFi signal is equal to 12-24 Mbit/s. However, download speed of photos from PC to Media server is approximately equal 1 Mbit/s. Also, the media server downloads files from torrent approximately equal 0.5 Mbit/s.

Other hand, I have 100 Mbit/s internet. If I download somethings on the computer I have download speend approximately equal 90 Mbit/s.

I do not believe that a signal so bad. Probably, I have problems with software. Or do I need to buy some hardware?

  • When you're talking about downloading something in your computer, are you talking about your Vivo PC or your Desktop on W7 ? – Tarek Jellali Mar 24 '14 at 8:38
  • @Tarek Jellali, I talk about my Desktop on W7. – Denis Mar 24 '14 at 8:40
  • I see. So for your VivoPC, try to place it near the router and test copiying something. That will help you to be sure that it's a signal issue not a hardware/driver issue, if you still have low data rates, try to connect your VivoPC with an ethernet cable an monitor if the data rate is still low. Edit : Prefer copying large files like 20MB. – Tarek Jellali Mar 24 '14 at 8:45
  • @Denis | Are you sure you have 100Mbps network connection? Are you sure you don't mean bytes? Can you connect your server to LAN via ethernet? – Matthew Williams Mar 24 '14 at 8:46
  • @Tarek Jellali, thank you for your idea. It is a sensible idea. – Denis Mar 24 '14 at 8:54
1

I think you may have two different problems going on here. One is that you're not getting the throughput you should expect given the Wi-Fi PHY rates you're getting, and the second is that you could do a lot better, Wi-Fi hardware-wise, than your current AP+STA (wireless router plus wireless PC) combination.

Insufficient throughput given PHY rates

If you're really getting the 12–24Mbit/s PHY rates on your Wi-Fi link, you should expect TCP throughput of about half that, so 6-12Mbit/s (so around 0.7–1.4 MebiBytes/sec). But this is only if you're using software that makes efficient use of TCP.

As a double-check, run a quick IPerf test. Make your VivoPC the IPerf server (-s), and your Win7 desktop on Ethernet the IPerf client (-c). Run a 10 second or 60 second test with default settings, then add -w 2M to both the IPerf client and server, to force a bigger TCP window on both ends, and see if it's any faster when the TCP window is forced to be plenty big.

If you get 6-12Mbit/sec running IPerf, it's an indication that whatever software you've been using to do your file copies has been inefficient.

Better Wi-Fi performance through better hardware

Your VivoPC claims it has 802.11ac, but it turns out it's using a RealTek RTL8821AE combo module which only handles a really crappy level of 802.11ac support known as "1x1:1" or "1 spatial stream". That means that even with a state-of-the-art high-end 2014 802.11ac "AC1900" AP, it could only do 433Mbit/sec tops, whereas most decent 802.11ac clients support 2-3 spatial streams, meaning they can do 2-3x that speed. I can't find info on what channel widths that chipset supports, or what the particular module in your VivoPC supports, so it's possible that it only supports 40- or 20-MHz-wide channels, meaning it may be as slow as sub-100Mbit/sec signaling, even though its technically 802.11ac.

You're certainly not doing it any favors by pairing it with a 2.4GHz-only, "N300" AP. Because your 1 spatial stream VivoPC can only do 1 spatial stream in 802.11n as well, so that means it's only capable of "N150". But on top of that, since it's a Bluetooth combo module, it probably insists on only using 20MHz-wide channel operation when in 2.4GHz, so that Bluetooth has some room to work (trying to use 40MHz-wide Wi-Fi channels in the 2.4GHz band hogs too much of the band and kills Bluetooth). So this combination of factors probably means that your VivoPC would max out at 65 or 72Mbit/sec PHY rates, which is barely better than 2002's 802.11a or 2003's 802.11g rates of 54Mbit/sec.

To get a lot better Wi-Fi throughput, consider upgrading your AP to an Asus RT-AC68U, which gives you state of the art 802.11ac with 3 spatial streams, 80MHz-wide channels, and high-powered transmitters, and still supports your legacy 2.4GHz devices simultaneously. Also disable the VivoPC's lame "AC in name only" built-in Wi-Fi, and instead plug in a USB 3.0 super speed, 2 (or 3) spatial stream 802.11ac adaptor, such as an Asus USB-AC56 (not the USB-AC53, which is hobbled by being USB 2.0).

0

I have the same Vivo PC with the same problem. I found the solution to the problem here: http://answers.microsoft.com/en-us/windows/forum/windows8_1-networking/problem-with-realtek-8821ae-wireless-on-windows-81/e875a73f-842a-40e9-a34d-89f6999ff48f?auth=1

In the Device Manager double-click the Realtek wireless adapter > Power Management Under the Power Management tab un-check "Allow the computer to turn off this device to save power" > OK

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.