I work with many CSV files, and am constantly annoyed by the Excel dialog that pops up when I try to save a file:

"[your spreadsheet] may contain features that are not compatible with CSV (Comma Delimited). Do you want to keep the workbook in this format?"

My answer is always going to be YES. Is there a registry setting to suppress this confirmation dialog?

  • Probably not. Is a macro an option for you? – DaveParillo Nov 20 '09 at 22:41
  • There's an Excel AddIn (with source) for my related question How to Export -- not Save As -- to another format? that can help with this. – matt wilkie Oct 7 '15 at 16:03
  • In office version 1611 Build 7571.2075 (personal subscription), I see a checkbox setting under File/Options/Save, "Show data loss warning when editing comma delimited files (*.csv)" However, it is unchecked and I still get the warning. On another computer that's on the deferred channel with version 16.0.6965.2115 (work subscription), this option is not available, yet I somehow got it to stop pestering me when saving csv. I'll contribute an answer if I ever figure it out for real, but I'm hoping they're in the process of implementing a functional solution with that checkbox. – David Brown Dec 23 '16 at 23:19

This is a common problem all Excel users suffer. I think, the only way to do that is to use a macro. For example:

Application.DisplayAlerts = False
With ThisWorkbook
    .SaveAs Left(.FullName, Len(.FullName) - 3) & "csv", xlCSV
End With
Application.DisplayAlerts = True
| improve this answer | |
  • would Left(.FullName, Len(.FullName) - 3) & "csv" mean in case of a foobar.xlsx a new filename foobar.csv, right? this omits the save dialog, and having custom names, right? in that case it is worth to note that if your workbook 'file' contains multiple worksheet 'tabs', then CSV can only can save the active one. and this would be better if addressed with the naming in my opinion, if possible! (unfortunately not a macro guy myself yet) – n611x007 Feb 13 '14 at 10:26
  • 5
    how does one add this macro...? – dwenaus Oct 7 '15 at 0:22

I have Microsoft Office 365 ProPlus and today I noticed for the first time ever, Excel asking me if I want to disable CSV save notifications. I realize not everyone has Microsoft Office 365 ProPlus subscription but if you do, this might help. My version shows "Version 1609 (Build 7369.2118).

If you visit this link: Disable CSV Warning

It will show you where to find it. It's in:

File > Options > Save > Under 'Save workbooks' find checkbox that says "Show data loss warning when editing comma delimited files (*.csv)"

| improve this answer | |
  • 1
    hmm. I don't see it in my excel. Just for that I wish I could upgrade – userJT Oct 17 '19 at 13:38

I addressed it with ClickOff. The site it was hosted on is down, but I uploaded it here.

| improve this answer | |
  • 1
    Worked for me. Looks like his link moved here. I downloaded the program, assigned it to English, and went through the prompts in Excel using Ctrl+Alt+D and now it auto clicks on the prompts! – SomeGuyOnAComputer Sep 26 '16 at 17:28
  • ok interesting solution but you need this program to run in the background. – Herman Toothrot Dec 21 '16 at 10:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.