16

I have a Debian Wheezy VM running in virtual box with the 1st adapter being NAT. However I want to also add a Host-only network but I can't add 2nd adapter to network for VM, it is grayed out.

Any ideas?

0
23

Make sure the Virtual Machine is powered off. VirtualBox will not allow you to modify the network adapters while the VM is running.

5
  • Although this answers the greyed out part, adding the adapter still doesnt unction, i have tried putting bridge, nat, or host-only in adapter 2, and none of them will function as they should, i.e. no connection. i can only get adapter slot 1 to function. im behind a corp network, not sure if that has somethng to do with this. – Brian Thomas Aug 17 '17 at 22:10
  • @BrianThomas are you able to add the adapter and it just doesn't work or is VirtualBox preventing you from adding a new connection? – heavyd Aug 17 '17 at 22:59
  • 1
    It just didnt work, i was able to add the connection. I had to run sudo dhclient to enroll it, i later found. Thanks for your response. Who would have known? askubuntu.com/questions/7874/… I think maybe this is a bug in vbox? I will next look for a way to automate this for reboot. – Brian Thomas Aug 18 '17 at 0:13
  • @BrianThomas, did you ever find a solution to automate this on boot? – Tyler Crompton Apr 16 '18 at 15:19
  • @TylerCrompton, sorry mate, I dont think I had the time to find one, and no longer using it. – Brian Thomas Apr 23 '18 at 17:51
4

If the VM is not running, and is in a saved state, you need to start it, then from the VirtualBox Manager, right click and select Close > Power off. You can't add a network adapter in the saved state.

Also, if required, remember to setup your proxy details in VirtualBox Manager. Power on the VM, then setup proxy details for IE.

1

I had the same issue, and solved it as follows:

  1. Restart the computer.
  2. In Preferences - > Network of VirtualBox (not the VM) added a host-only interface.
  3. Added a Host-only adapter to the VM.
0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.