0

I have a strange issue with clonezilla. I try direct disk to disk clone from a smaller drive to a larger one. It is a windwos 7 disk with 200mb system, the main partitions, a data partition and small recovery partition.

SDA1 is the 200mb partition and it fails to copy to SDC1 because the target is 2Mb.

SDA2 is 296Gb and fails to copy to SDC2 because it is 200Mb.

So it is as if clonezilla copy the partition table wrong with an extra 2Mb partition.

I tried expert mode -k1 to have it interpret the size difference. Same thing happens.

Hints: I had cloned a SSD drive to this HDD before (and it worked fine). In the world of SSD cloning I have seen issues with partition alignment. Maybe this is where the hidden 2MB comes from? And the source HDD is a dynamic disk. Maybe clonezilla cant handle dynamic?

I made the 5 partitions manually as a basic disk, and had trouble with parition 4 and 5 as basic discs can only handle 3 primary partitions. I had to make the last two "Extended". So clonezilla was able to copy the first 3 partitions and then it hit a "invisible" 1Mb partition again. I had copied the last two one by one.

Then I couldnt boot. Tried windows 7 rescue disk and bootrec.exe . didnt work. "cant find the system device", it said. 2 hours later I found out I just had to use win7re from another usb port. then bootrec /rebuildbcd worked fine.

Then I booted and it took twice as long to boot on the new 7200rpm than the old 5400rpm drive... Then I looked into this "advanced format" drive technology and it seems the partitions has to be aligned after a clone. WD Align said they already were aligned (since I made the partitions in win7.

So why is a newest gen WD Black 7200 rpm drive 2x slower than an 2011 Toshiba 5400rpm drive?

Parts: WD7500BPKX and mk6476gsx

Benchmarks give approx 800 points to the new WD and 500 points to the old toshiba.

The toshiba is a 2 platter thing and if the new WD Black is like the old ones it is 3 platter. that means 1.33 factor on density, to counter the 1.333 speed. in total it should give the same speed at at least. is the Adv Format design supposed to be half speed?

3
  • You are sure that you are doing disk based and not partition based? One way around this is to manually create partitions on the target device that are at least as large or slightly larger than the source, and then do a partition based clone. Partition based clones are often a bit more efficient (timewise) than disk based clones.
    – nod
    Mar 24 '14 at 21:35
  • yes I do disk to disk. To ensure that it makes it bootable. but what is hte 2mb about? its supposed to copy the partition table, so part 1 is the same as part 1 and not have an extra 2mb part. if I do the manual partitions, how do I make it bootable again, and can I be sure that the 2mb invisible partition wont screw up the boot table? I made a disk to disk copy from a SSD to the target drive and it booted fine. then I copied a HDD to it and it does this silly thing. Mar 24 '14 at 21:52
  • part to part did work, but the drive is hilariously slow , despite being newer gen and faster rpm. Mar 30 '14 at 14:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.