34

I'm facing this strange problem from yesterday where if I select NAT as the network adapter in VMWare, I'm not getting any internet connection in the VM. I have a requirement where I have to have the network adapter as NAT.

Internet is working properly in my host machine but not working in my VM. It shows that the internet cable is unplugged. I'm getting a 'X' mark on the internet icon.

Even if I'm connected in Wi-fi or LAN, I'm getting the same issue.

My host machine is Windows 7 Professional and VM is Windows 7 Professional N.

Any idea what could be the problem. I have referred to other links similar to my problem but they didn't seem to provide the solution to mine. Most of them asked to connect using Bridged adapter.

Any suggestions will be very useful.

1
  • Did you shared Host Internet Connection to the NAT VMnet? You can do this from Network and Sharing Center. Follow steps in this tutorial. youtube.com/watch?v=H2j3nyl4muQ Aug 31, 2017 at 13:42

15 Answers 15

25

You don't need to necessarily reinstall VMware. You might lose custom config and preferences, if you do so.

Here is a simple fix

  • Edit > Virtual Network Editor

enter image description here

  • Grant Admin Privileges

enter image description here

  • You shall see all network adapter to configure, tweak those to your needs
  • If you don't know what those are, simply click Restore Defaults

enter image description here

2
13

I resolved the problem. Though the solution seems to be pretty lame.

I observed that VMware DHCP service had stopped running and was not restarting at all, no matter what I try.

So I had to uninstall and re-install VMware workstation to make it run.

After reinstallation, I started getting internet with NAT adapter.

But I'm still not sure why the service was not starting.

7
  • This is the only solution that worked for me! And I have tried many from various online forums. Apr 1, 2015 at 16:50
  • 2
    maybe is late, but you should be tryed start>run>cmd and type NET START "VMware DHCP Service" and press enter. Aug 12, 2015 at 13:10
  • Hello @FranciscoTapia. Sorry for the late response. I had tried this as well but it kept failing. Tried with cmd prompt in admin mode too but with the same issue. That's why had to resort to this method.
    – Amogh Natu
    Sep 28, 2015 at 12:35
  • This worked for me, too. I had converted (imported) my VM into my new Fusion app. The VM started up but couldn't NAT. I uninstalled Fusion, reinstalled, and now my VM has Internet access. Dec 11, 2018 at 20:37
  • 1
    Basically my windows OS got an update and VMware didn't start this service for me as well. VMware DHCP Service you will have to run services.msc as admin to start it again. Jul 2, 2020 at 16:39
8

In my case, it was VMWare NAT service that was not running. I started it by going to services.msc and the internet started working on the guest VM. In the Virtual Machine Settings, choose NAT as Network connection.

1
  • 2
    This worked for me! My VMWare is set to NAT connection so that's why. So I think the solution is the following: Go to services.msc and start whichever service corresponds to your type of connection, NAT or Bridged (DHCP), etc. Jun 8, 2019 at 6:37
4

I too had faced the issue, took a long time for me to figure out what was wrong. Finally all I did was to start the DHCP Service from the task manager which was stopped and it worked fine.

task mangaer VMware services -DHCP

3

If you are working in a multi Nic card server, you must to select which Nic will be in use.

In VMware Workstation:

  1. Go to Edit, Virtual Configuration Network
  2. Select the VM Nic auto-bridging
  3. In VMNet Information, select bridge, and
  4. In the option "bridge to" select the correct NIC card used by the VMware Workstation.
1
  • 1
    This was the solution that worked for me; not sure why "automatic" no longer worked. Feb 11, 2018 at 18:04
2

Came across this issue on Windows 10 - VMware Workstation 15. None of the answers here helped and from the get go all of my VMware related services were running.

The only thing that fixed the issue for me was to go to Start > type services and opened the Services Manager. Here I found VMware NAT Service and right clicked selecting Restart:

enter image description here

Simply restarting the system may have helped but I was looking for a quick fix that didn't interrupt my running Virtual Machine's.

1

try starting the network service on your VM machine. you can use this command for linux: sudo nmcli networking on

1
  • Welcome to Super User! Before answering an old question having an accepted answer (look for green ✓) as well as other answers ensure your answer adds something new or is otherwise helpful in relation to them. Here is a guide on How to Answer. There is also tour for the site tour, and help center for the help center. Mar 12, 2021 at 11:04
0

In my case, problems appeared with NAT after a VM pro v15 update. VM tools upgrade in each VM did not help. Here's what I did in chronological order :

  • "Repaired" VMware (via "control panel" | "add/remove programs") and rebooted the host machine. This did NOT fix the problem.
  • Removed all network adapters from VM (Edit | Virtual Network Editors...)
  • Added one new NAT... then restored the subnet to what it was previously (with all the network issues it was burned into memory months ago).
  • Subsequently started each VM and of course the network was still NOT working each time.
  • From the VM (host) menu for each VM I reconfigured the network adapter to "custom" and selected the virtual network I created above.
  • The network adapter now works in each VM.
0

In my case, I removed Network Adapter and CD drive and added it again. It worked fine.

enter image description here

0

if you are on Mac and would like to reset you can use this link: https://kb.vmware.com/s/article/2009642

you can continue to run

> sudo /Applications/VMware\ Fusion.app/Contents/Library/vmnet-cli --stop 
> sudo /Applications/VMware\ Fusion.app/Contents/Library/vmnet-cli --start 
0

I powered off the virtual machine. Turned it back on. It worked. Simple as that. Lots of guides even on the VMware community forum didn't work for me.

Windows 10
VM Machine: Ubuntu
VM State: I mostly keep VM's suspended, never power off.
Software: VMWare

And there was no settings issue either. Just a restart and everything worked as it was working before.

0

Somehow it worked for me but internet is working slow now -

--> Goto windows10(i.e., your Host machine) start > Run > services.msc and over here as @Sabe Barker mentioned restarting the VMware Nat Service.

& then coming back to VMware --> VM > settings > Network Adapter > NAT > OK

That's it !!!

1
  • Your answer could be improved with additional supporting information. Please edit to add further details, such as citations or documentation, so that others can confirm that your answer is correct. You can find more information on how to write good answers in the help center.
    – Community Bot
    Dec 27, 2021 at 19:46
0

I tried every solution except VMWare reinstallation. However simple solution from this article at vmware support worked fine. Start your VM, then Suspend and Resume it. Power off didn't worked out for my case

My setup:

  • Win11 - Host OS
  • Ubuntu 20.04 - Guest OS
  • VM Ware Workstation Pro 16.2.3 build-19376536
New contributor
Sergei Churbanov is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.
-1

Well, i had the same problem. My host is Windows 7, VM is Ubuntu and I'm using Workstation.

So i just returned the defaults configuration in the Virtual Network Editor and then everything was ok.

3
  • I tried that as well. But the problem still continued. So had to use the standard "solve everything" solution of uninstalling and re installing the work station. And that worked out for me.
    – Amogh Natu
    Nov 12, 2014 at 17:57
  • What is Virtual Network Editor? Apr 1, 2015 at 16:41
  • @IgorGanapolsky It's just a menu option. Go to Edit->Virtual Network Editor on VMware Workstation: i.imgur.com/vbV65jA.png Jun 8, 2019 at 6:40
-1

It happens when you shut down your host machine without saving machine state of VM. You can just restart your virtual machine. It will solve the problem.

1
  • I'm going to give an upvote for the part where you said it happens when you shut down your host machine without saving the machine state of the VM. I just realized that was the cause of the problem, so I know how to troubleshoot it in the future The solution suggested of restarting the virtual machine does not help, though Jun 8, 2019 at 6:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.