42

I'm on OSX 10.9.2 using a Samsung SA850 Display connected to the display port of my MBP 15" Late 2012 Model.

All seems fine, but there is a problem with audio. Generally, whenever the display goes to sleep and wakes up again, my audio stops working. I found out that this is because the display has an integrated audio device, so for some reason this seems to mess with my system settings. I have no idea why.

This is kind of a clueless approach, but perhaps anyone knows how I can just totally stop OSX from even considering my display as an audio output device?

  • @CummanderCheckov did you find a solution? – codecowboy Aug 21 '14 at 13:30
  • 1
    See if the display port shows up in Sound properties "playback" tab, if it does, disable any display port entries in there. – Moab Dec 28 '14 at 20:47
9

Make the sound icon visible in the menu bar (at the bottom of the Sound system preferences window), then hold Alt ⌥ and click it to view all possible outputs. Sometimes the actual Output window in system preferences doesn't actually display all available options.

|improve this answer|||||
  • 11
    This is not an answer to OP's question :-| – Holene Jan 30 '19 at 8:43
  • 3
    There is no way to disable an audio device from that menu. This question is about disabling a device entirely so MacOS will not switch to it automatically – Brandon Oct 5 '19 at 3:09
7

Same problem with Sierra and a Dell P2715Q, here. It seems like a display with no audio shouldn't trigger this, but ¯\_(ツ)_/¯

With the display connected and no headphones, I used the Sound preferences to change the output to Internal Speakers. Now, at least for this user, the MacBook understands that I never want the sound output routed to DisplayPort.

|improve this answer|||||
  • 1
    The Dell has a breakout for a sound bar. I think we can blame that. – Journeyman Geek Mar 2 '17 at 13:41
  • Ah, that at least explains why. I'm happy to report that this simple solution has been working well for 4 affected users. – gerwitz Mar 3 '17 at 14:47
  • Just tested this with High Sierra & the Dell P2715Q and can confirm this seems to work. Used sound preferences to change audio output device to Internal speakers > unplugged external monitor > waited > plugged external monitor in again > audio output device is still set to Internal Speakers. – Josh Buchea Dec 14 '17 at 17:12
2

I suppose you could turn the sound off on your monitor using the buttons. You could also just use a connector like vga or dvi to get rid of sound output.

|improve this answer|||||
0

macOS 10.15.1 with 2018 MacBook Air

I just found an App that might fix this problem. I was having the same issue with my Dell P2715 monitor when using video conference apps like Skype and Zoom.

The name of the app is "Audio Profile Manager" by Septimal Mind Limited, only $3.99 but these are things Apple should have solved it by including such function as an option...

|improve this answer|||||
0

Plug an AUX cable into the monitors audio output without the other end of the cable plugged into anything. You have to leave it dangling there at all times but it will solve this problem.

This is also solved the related problem of my bluetooth headphones staying connected but no longer playing audio every time I connected to my monitor.

|improve this answer|||||
-1

I havn't had a Mac for quite a while now, but I'm pretty sure you can't. I think somehow it must be possible to deactivate the proper kernel device that's responsible for sound over HDMI/DisplayPort but it's hard to say how easy this can be accomplished, how that will corrupt functionality or how easy it will be to reverse. Someone should confirm this but I think you could get a cheap usb sound card, which would allow you to completely ignore the internal soundcard, thus only showing you devices connected to the usb card. Or maybe a software solution, something like AudioMate for example could do the trick.

UPDATE: NOT WORKING. SEE COMMENT BELOW

But I would suggest you do the following: It's kind of a strange solution but it'll work and pretty much everyone has the know-how to do it.

  1. Take a look at the pin assignments of DisplayPort
  2. Get yourself a spare DisplayPort cable
  3. Cut it in the middle and solder all the pins back together, avoiding the pins connecting audio. (These should be pin 15-17)
  4. Use the cable to connect your display
  5. Be happy!

    Pin 1   ML_Lane 0 (p)   Lane 0 (positive)   
    Pin 2   GND Ground  
    Pin 3   ML_Lane 0 (n)   Lane 0 (negative)   
    Pin 4   ML_Lane 1 (p)   Lane 1 (positive)   
    Pin 5   GND Ground  
    Pin 6   ML_Lane 1 (n)   Lane 1 (negative)   
    Pin 7   ML_Lane 2 (p)   Lane 2 (positive)   
    Pin 8   GND Ground  
    Pin 9   ML_Lane 2 (n)   Lane 2 (negative)   
    Pin 10  ML_Lane 3 (p)   Lane 3 (positive)   
    Pin 11  GND Ground  
    Pin 12  ML_Lane 3 (n)   Lane 3 (negative)   
    Pin 13  CONFIG1 connected to Ground1)   
    Pin 14  CONFIG2 connected to Ground1)   
    Pin 15  AUX CH (p)  Auxiliary Channel (positive)    
    Pin 16  GND Ground  
    Pin 17  AUX CH (n)  Auxiliary Channel (negative)    
    Pin 18  Hot Plug    Hot Plug Detect 
    Pin 19  Return  Return for Power    
    Pin 20  DP_PWR  Power for connector (3.3 V 500 mA)
    
|improve this answer|||||
  • 1
    I like your thinking, but audio in DisplayPort (and HDMI) travels over the main link, not the aux channel. :( – joerick Apr 28 '16 at 18:41
  • I made a note in ma answer @joerick – farosch Apr 29 '16 at 13:47
  • -1 on this "answer". Display port carries power (3.3V, 500mA specifically). Taking a hacked together cable like this can damage your equipment. If you're reading this answer, don't do this. – Urda May 29 '18 at 22:00
  • You should just take out the entire "not working" part, it does no good to have an answer that doesn't work and worse, it could damage a device. You can just put a note that says "since the audio stream runs over the main channel with video, the cable can't be hacked to remove audio". As it is now the answer says both "Not working" and "it'll work". – Johnny Jan 2 '19 at 18:07
  • There is an audio pin?!!!! Wow that is great news. And naughty Apple for making this so hard. :) – Tomachi Apr 23 '19 at 12:55
-1

Even though I have never chosen to hear the awful sound output on my AOC monitor, macOS stubbornly switches at full volume each time I plug in the monitor. Here you can see I am trying to disable it by creating an aggregate device, but after doing this I end up with no volume controls and at 100% volume. So I can't say this works, and consider hacking my HDMI cable open.

enter image description here

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.