2

I installed Intel ssd 520 (180GB) into my HP 8560w notebook with Windows 8.1. The system works fine, if no HDD ATA password set. However I wish to take advantage of the encryption feature, so I have set an ATA master and user password (in the BIOS). Problem is that setting the ATA password causes the system to blue screen (STOP 0xF4) when waking from a sleep state.

Event viewer shows Error Event 41-Kernel power (critical), "system has rebooted without cleanly shutting down first". It seems, like the SSD remains locked after resuming from SLEEP. In order to figure it out, I disabled ATA password for Intel SSD, using password just for my secondary HDD (Hitachi magnetic non encrypting drive) in upgrade bay. This works fine, notebook is able to resume from SLEEP, secondary drive is unlocked and available. So it seems, that it is intel ssd to cause the problems, not the bios. Is there any solution? There is similar post in the intel forum, but without any reasonable solution. https://communities.intel.com/message/168612

I run Windows 8.1 x64, latest updates, latest bios, latest 520 firmware (i400). SATA in AHCI mode. Thanks

1

Well, after a week of experiments I will try to summarize my experience.

Short

There is probably no way to get Sleep working together with DriveLock on HP 8560w and Intel 520 SSD.

Long

Either disable Sleep or disable DriveLock. I tried both, BIOS mode and UEFI boot with guid partition table. It is either a messy BIOS or strange implementation of security in 520 (SSDSC2CW180A3). I have a secondary non-SED Hitachi in Ultrabay module, which works correctly even with ATA password enabled.

Intel 520 in not TCG Opal compliant. None of the software tool (neither the HP DriveEncryption nor Bitlocker) offers the possibility to use hardware FDE with 520).

Hibernation and cold restart work fine with DriveLock enabled on Intel 520.

HP 8560w does not support UEFI 2.3.1., required by Win8 to provide Secure boot. Enabling UEFI boot in 8560w is experimental. If enabled, Bitlocker fails to turn on with error message, that TPM doesn't work with current BIOS. I am running current version of BIOS.

Here are the links to HP and Intel support forum, where it was discussed. http://h30499.www3.hp.com/t5/Notebook-HP-ProBook-EliteBook/8560w-Windows-8-1-BSOD-when-waking-from-sleep-if-ATA-HDD/m-p/6431152#M178660 , https://communities.intel.com/message/229380

HP Support page is messy. It offers obsolete or no downloads for Windows 8 and 8560w. For current version of HP software one should use the support page for current products (Zbook or 820 G1).

I hope this summary will save someone's time and pain...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.