0

I'm using a robocopy script with the switches /COPYALL and /B on my Windows 7 Home Premium PC to backup files to a NAS and I'm getting the error message:

ERROR 1314 (0x00000522) Copying NTFS Security to Destination File (file-location/name) required privilege is not held by the client.

I think it is something to do with account privileges in Windows 7 Home Premium - I read somewhere you need to add the account to the Backup Operators group - but that is for the Server OS.

How can I overcome this problem without upgrading to Windows 7 Pro?

Note: The other Win 7 computer on the network which is Pro does not have this issue.

1
  • Download the Windows Server 2003 Resource Kit Tools. Extract the rktools.exe downloaded file using 7-Zip. Then extract rktools.msi. Among all the files there's one called ntrights.exe. To grant backup privileges to a specific user, run this command from an elevated command prompt: ntrights.exe -u "some_user_name" +r SeBackupPrivilege – and31415 Mar 27 '14 at 10:53
1

this option should solve the problem and will copy the attributes required.
/COPY:DATSO

Here is more description on this

/COPY:copyflag[s] :: what to COPY for files (default is /COPY:DAT).

(copyflags : D=Data, A=Attributes, T=Timestamps).

(S=Security=NTFS ACLs, O=Owner info, U=aUditing info).

3
  • It's the 'U' option which causes the failure – smirkingman Nov 23 '18 at 13:23
  • @smirkingman hey, I did not understand what you mean by causing failure. can you explain? – Baljeetsingh Nov 26 '18 at 16:57
  • For me, DATSO worked but DATSOU failed. I concluded that 'U' was the problem – smirkingman Dec 10 '18 at 13:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.