I am using OS X Lion, and have all my calendars (15) created in google calendar, but in my laptop I use iCal for syncing with my google calendars and working with them. The problem is that just for some of the google calendars that I edit and modify in iCal, if I create events in iCal (for the google calendars), the events dissapear past 10 seconds, although they seem to exist in google calendar. Any hints?

  • Does this help? – Vinayak Mar 29 '14 at 17:46
  • the link is about alerts, but my problem is that whole events do not show up on ical while they do exist in google calendar – Open the way Mar 29 '14 at 19:20
  • Is your problem related to "message with sound" (not supported by google)? – harrymc Mar 30 '14 at 11:25
  • I do not know what you are talking about, can you add some link? – Open the way Mar 30 '14 at 12:22
  • This is also for alerts, which doesn't sound like your problem. – harrymc Mar 30 '14 at 12:51

In the google-forums, many people had the same issue. One answer seems to help many users, because of the number of upvotes:

I saw this earlier today and saw everyone said this was impossible. So, as my friend Barney Stinson would say "Challenge Accepted"

  1. Go into iCal and export all calendars separately.
  2. Go into Google Calendar (gCal) and create the same calendars from your iCal.
  3. Import iCal events into the appropriate gCal calendars.
  4. Delete all calendars from iCal. (You have them saved already so just incase it doesn't work, it won't take long to fix).
  5. Go into iCal preferences and delete iCloud account.
  6. While in iCal preferences, add your Google Account.
  7. Choose the option to synchronize every minute (just so everything stays up to date).
  8. While in the newly created account, tab over to "Delegation" and select all of your calendars, this way you can see all of them.
  9. ...You're done. You'll have to set all the colors again though. And because I may have OCD, make sure the iCal and gCal calendar colors match please.
  10. Test it out! (It may not show up until you hit refresh)

You may be thinking, wait I deleted my iCloud, now my iPhone Calendar won't be up to date.

I fixed that problem too. Im a boss.

Here's what you do on the iPhone:

  1. Go into Settings --> iCloud and turn off calendar.
  2. Go into Settings --> Mail, Contacts, Calendar and create a Gmail account and choose the option to sync calendars. (Note: If you are using google to sync your contacts, then you're using and exchange account. You must keep the Exchange account to keep your contacts. The calendar, even though it may say on, won't sync unless you have a Gmail account hooked up.
  3. Go into your calendar and if the calendars aren't selected, select them.


|improve this answer|||||

Have you tried to see if you can replicate the issue with Mavericks? You're 2 versions behind and it's possible that this has been already addressed by either Apple or Google.

If you don't want to or cannot upgrade your computer now and have a fast USB drive of 32GB or more, you can install 10.9.2 on that, boot to it from your computer (hold the Option key while booting) and test without updating you system. There are many tutorials you can find to walk you through this step by step. HTH

|improve this answer|||||
  • The thing is that I do not want to do the OS update. I am afraid my late 2008 macbookpro will experience some problems. – Open the way Mar 31 '14 at 7:10
  • Please read my post again. I said you can install Mavericks to a blank USB drive and boot from it WITHOUT changing your Lion install. I think tje problem may be specific to Lion so this way you can troubleshoot without having to upgrade. – SaxDaddy Mar 31 '14 at 7:21
  • ok, I understand it now. I think I will have a look, thanks – Open the way Mar 31 '14 at 13:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.