0

After upgrade to Windows 8.1 I'm unable to connect to WiFi at work.

enter image description here

PC is using Broadcom 802.11n Network Adapter

Computer is joined to domain and have to problem with anything over wired connection. At home using WPA2-Personal have no problem connecting to WiFi.

Steps taken:

  • Uninstall and re install WiFi Driver.
  • Install driver from computer manufacturer
  • Install Legacy Driver
  • Disable/Enable WiFi driver.
  • Upgrade to BIOS
  • Upgrade to motherboard drivers.
  • ipconfig /release and ipconfig /renew

Additional information:

My laptop is Latitude E6520

Working with network engineer at work was able to verify that PC is connecting to DHCP and getting a IP address leased. Domain shows successful authentication. Firewall is disabled and User Account Control is set on lowest. Current user is added to Administrator group.

Note: Several other users with recent upgrade to Windows 8.1 have reported same problem. Everyone with issues is using some version of DELL Latitude. Once connected to WiFi, get Limited Connectivity message.

  • These other users using similar hardware? – Ramhound Mar 27 '14 at 15:37
  • Also Dell laptops but newer models. – Vladimir Oselsky Mar 27 '14 at 15:38
  • The drivers you are installing specifically support Windows 8.1? – Ramhound Mar 27 '14 at 15:44
  • Dell only list drivers for Windows 8 i have not seen anything that said 8.1 specifically. – Vladimir Oselsky Mar 27 '14 at 17:01
  • That's unfortunate because there are differences between the two kernels – Ramhound Mar 27 '14 at 18:06
1

After more searching I found solution that worked for me

  • Open Device Manager

  • Select Network adaptors and then select Broadcom 802.11n Network Adaptor

  • Right click and select Update Driver Software

  • Select Browse my computer for driver software

  • Select Let me pick from a list of device drivers on my computer

  • Uncheck Show compatible hardware

  • Select the Broadcom 802.11n Network Adaptor, and click Next (I got warning message in regards installing outdated driver)

  • Restart PC and enjoy WiFi

Solution was also tested on another computer in the company with good results.

| improve this answer | |
  • You will most likely have more than one driver listed. Here's the key that did it for me. Don't pick the latest driver (6.30.223.102 for me). Instead, pick the previous driver (5.100.245.200). Everything woke right back up for me after doing this. – Mel Oct 13 '14 at 22:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.