3

I have Visual Studio 2013 (tested with Update 1, 2 and 3) installed on two completely seperate machines, one is Windows 7 SP1 and one is Windows 8.1. Both are running the latest version of Firefox and Firefox is set to be the default browser. The Firefox setting "Open tab instead of new window" is checked.

Almost every time I want to open the API help pages on MSDN by pressing F1 in the code, a new Firefox window is opened. This happens on both machines. But it only happens with Firefox, when IE is the default browser it correctly opens a new tab. And this is a new problem in Visual Studio 2013, I didn't have this problem with Visual Studio 2010.

Interestingly, this is not 100% consistent. Rarely, I'd say about 5% of the time, it correctly opens a new tab instead of a new window. And I have found one command that always correctly opens a tab, that is the Help - View Help command in the main menu bar (not very helpful).

Searching the internet revealed this Microsoft Connect issue entry which says that it was also a problem in Visual Studio 2012, but was apparently fixed in the latest build in May 2013. While I've never used Visual Studio 2012 myself, this date was before Visual Studio 2013 was released, and was far before Update 1 for it was released. Did they really forget to merge the fix to Visual Studio 2013?

Anyway, my question is if everyone experiences this problem and if not, if anyone knows a way to fix it.

Update with workaround

I've no idea how or why this works, but I've found a workaround. As long as the .NET Reflector (I'm using version 8.3.3.115) is running, the F1 key works correctly. This is 100% reproduceable and works on Windows 7 and Windows 8.1.

Can someone please explain that to me?

I'll leave this question open until a real answer is found.

Update 2

Visual Studio 2015 shows the same problem.

  • I've now created a new connect issue for this bug. If you also have this problem, please vote here. – cremor Apr 9 '14 at 11:25
  • Microsoft said that this is a issue in Firefox. While I doubt it, I've created a firefox bug here. Let's hope we get a helpful response. – cremor Apr 15 '14 at 5:42
  • This behavior can also be observed in VS2012, nothing new about it. Also, it isn’t fixed to date. – Daniel B Apr 30 '14 at 9:36
  • 1
    Have you considered install the more recent updates to VS2013/ – Ramhound Aug 26 '14 at 23:24
  • There is Visual Studio 2013 Update 3: support.microsoft.com/kb/2933779 – Devid Aug 26 '14 at 23:30
0

The problem is that Visual Studio launches Firefox with incorrect parameters. The correct settings can be found in the registry (HKEY_CLASSES_ROOT\FirefoxURL\shell\open\command). Now, to fix this, simply add Firefox as a web browser (with the correct startup parameters: -osint -url "%1") and assign it to the default.

  • How/where do I add Firefox as a web browser? Btw, VS launches Firefox with a single parameter, the URL. This is a supported case according to the Firefox documentation. – cremor Aug 27 '14 at 5:55
  • Right click on html/xml file in any project. Select "Browse with..." from the context menu. In the opened window click Add and specify the path to the Firefox startup parameters and name sample – Albert Akhmetov Aug 27 '14 at 21:20
  • I've configured VS exactly as you said, but the bug is still there. That setting in the "Browse with" window has no effect on the parameters used to launch Firefox when F1 is pressed. It only affects the "Browse with" and "View in Browser" commands. – cremor Aug 28 '14 at 12:07
  • Did you set up the newly added browser as default? – Albert Akhmetov Aug 29 '14 at 17:57
  • Yes. And it did affect which browser opened when I used the "View in Browser" command. But for that function the additional startup parameters weren't even needed. Even with the default Firefox entry that function opens a new tab. And, as already said, it didn't fix the F1 key press. – cremor Aug 31 '14 at 9:13
0

I don't know when this was fixed, but it doesn't happen with Visual Studio 2017 on Windows 10.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.