3

I've just bought a SanDisk Ultra USB 3.0 64GB flash drive. The spec says that the drive's max read speed is 80Mb/s.

I only have a USB 2.0 port, and I've made these tests:

  • Writing a 4GB file on the (freshly formatted) flash drive had initial speed of 20Mb/s, then after a few seconds dropped to about 7Mb/s.
  • Writing the same file to a WD Passport USB HD connected to the same port had constant speed of 20Mb/s.

Should I suspect that the flash drive is malfunctioned or there might be a legitimate reason for this?

3
  • Try a different port, then try the stick in another computer. Same results? Mar 28, 2014 at 18:58
  • 1
    On a different port I get the same. On another USB2 computer I got slightly different results - transfer starts fast (~30MB/s) and gradually drops to ~10MB/s. The drop on the first computer was much sharper. Anyway, I'd expect a constant 20MB/s. Mar 29, 2014 at 21:37
  • I have this issue as well on a different 3.0 flash disk. At first, I get around 48MBps write speed and then it drops to a constant 6MBps.
    – Spikatrix
    Jan 7, 2017 at 6:40

2 Answers 2

6

You cannot really draw a conclusion about write speed from read speed. Usually those tend to differ about some magnitudes and vary a lot between different devices.

The fact that you observe a drop of speed after a short time when writing to your USB key is most presumably due to your operating system writing buffered: For performance reasons your OS does not write directly to the USB key but to a so called buffer cache, assuming that it isn't really necessary to write the files immediately. In most cases, it would be perfectly fine to cache writes and do the real writing in the background later (that's perfectly true for hard disks, but not necessarily for USB keys). The drop is caused by bulk-writing bigger data and your OS decides that it shouldn't write to the buffer cache further.

This also is one cause that you need to explicitly eject removable devices before removing them physically.

4
  • I bet the new drive has write caching disabled and the old faster drive has it enabled. See my answer to "Is time a substitute for Safely Remove Hardware?" to see a step by step guide to get to the properties page to check to see if write caching is enabled. Mar 28, 2014 at 21:45
  • Great idea! I've tried enabling the write cache, but unfortunately got the very same result... Mar 29, 2014 at 9:36
  • Turns out there's really no connection between write and read speeds. I've found reviews of the same flash drive stating the exact same problem. Mar 30, 2014 at 9:16
  • assuming that it isn't really necessary to write the files immediately?! It's not true at all. Because when you copy a file with less than 1gb (in my case an ultra fit 32gb) , file will be copied with about 80mb/s! Assume a 800mb file in just 10 sec!
    – ABS
    Oct 29, 2017 at 12:14
2

Because as soon as you click copy it is instantly copied into RAM (not only) or some other faster alternative.This is known as cache.As soon as your cached data is used the copying has to use noncached data.

1
  • 2
    RAM is many, many GB/s not only MB/s like your pendrive.Also if you have usb 3 pendrive connect it to usb 3 port otherwise it will be bottlenecked
    – user42276
    Mar 28, 2014 at 19:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.