My laptop suddendly quit working, simply boots no longer, giving an error stating that it cannot find a disk where to boot from. I suspect that the harddrive is corrupted or broken.

Well, I booted the computer with my SystemRescueCd USB installation in order to take a looksy. I cannot get any sight of the harddrive, below are the commands I've executed and their output

fsarchiver probe simple

[======DISK======] [=============NAME==============] [====SIZE====] [MAJ] [MIN]
[sda             ] [DataTraveler 2.0               ] [   489.00 MB] [  8] [  0]

[=====DEVICE=====] [==FILESYS==] [======LABEL======] [====SIZE====] [MAJ] [MIN] 
[loop0           ] [squashfs   ] [<unknown>        ] [   259.99 MB] [  7] [  0] 
[sda1            ] [vfat       ] [SYSLINUX         ] [   488.23 MB] [  8] [  1] 

Here the DataTraveler 2.0 is my bootable USB stick with the SystemRescueCd on it.

fdisk -l

Disk /dev/sda: 512 MB, 512753664 bytes
56 heads, 32 sectors/track, 558 cylinders, total 1001472 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x0365986f

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *          32      999935      499952    b  W95 FAT32

I also skimmed through dmesg and tried to grep it for "hda", but found no indication of the hardrive.

lshw gives me some output for SATA controller and such, but can't really say what to look for in here.

Is this a lost cause and the hardrive is simply busted? Or is there something else I can do to discover the drive for mounting it and saving the data?


Another boot with SystemRescueCd and fdisk -l now shows the drive as

Disk /dev/sda: 250.1 GB, 250059350016 bytes
255 heads, 63 sectors/track, 30401 cylinders, total 488397168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x3421b7ec

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1            2048    27265023    13631488   27  Hidden NTFS WinRE
/dev/sda2   *    27265024    27469823      102400    7  HPFS/NTFS/exFAT
/dev/sda3        27469824   488394751   230462464    7  HPFS/NTFS/exFAT

and fsarchiver probe simple

[======DISK======] [=============NAME==============] [====SIZE====] [MAJ] [MIN]
[sda             ] [Hitachi HTS54502               ] [   232.89 GB] [  8] [  0]

Note: The USB drive mentioned above is now mapped as /dev/sdb

Attempts to mount the device give me the following output

root@sysresccd /root % mount -r /dev/sda1 /mnt/windows 
mount: special device /dev/sda1 does not exist

Same error also for sda2 and sda3 when attempted to mount.

Also lshw now shows the device details.

Update 2

One more thing I just realised. This time I booted SystemRescueCd so that it's fully loaded to memory. Maybe this has something to do with how the other drive is shown.

  • Does the drive show in the BIOS/UEFI? – ernie Mar 28 '14 at 23:10
  • @ernie, Yes, the boot order page shows IDE0 : Hitachi ... – resource365 Mar 29 '14 at 12:38

The answer was too close to see. After boot, SystemRescueCd prints out basic usage on the terminal. There, it says to use ntfs-3g to mount Windows NTFS drives for full read/write support. So, simply using the following command, I managed to mount the drive on broken laptop

ntfs-3g /dev/sda3 /mnt/windows

P.S. If one wishes to bee extra careful and avoid making any mess on the drive, it can be mounted read-only ro option. The documentation actually says that this should be used when Windows is hibernated.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.