32

I have this problem on my laptop: If my Fn key is pressed, the normal (PC-like) F1 - F12 keys will be triggered; when it isn't, then the special keys will be triggered (e.g. brightness control, sound volume).

Is there any way I can invert this, so that when I press the Fn key the special keys will be triggered and when I don't the F1 - F12 keys will?

14 Answers 14

12

That's probably due to an extra option in the BIOS made by the manufacturer. When booting press F2 (usually) to get into the BIOS settings and there you can revert back to function keys instead of multimedia.

Have you tried to press the numbers lock key to change the fn keys functions?

74

On my Dell XPS 15, it seems to be as simple as me accidentally pressing the Fn Lock button behind the Escape key. If you have this problem, simply hit Fn+Esc and it should revert back to normal, without having to go into the BIOS

  • 2
    Also some ThinkPad laptops (in my case me E440), the Fn+Esc solved the problem. Thanx! – Jan Matousek Dec 26 '15 at 9:21
  • 2
    Excellent! I didn't even see that little lock symbol with FN inside it on the ESC key. Kinda obvious once you know what it is. :o) – Kenny Apr 27 '17 at 14:57
  • 1
    Oh wow, what a lifesaver! – David Brossard Sep 4 '18 at 1:15
  • Even worked on my non Laptop Keyboard "Leopold FC 660M" (I pressed "FN + 1" to revert back to normal). – Christian Strang Oct 17 '18 at 12:22
5

On my Dell laptop I pressed Fn + Esc and the problem is solved for me. If you closely notice, there is a small lock (Fn written on it) sign on the Esc. Apparently, you can change the default behavior of Fn key using Fn + Esc.

4

I had the same problem using a Lenovo Ideapad.

Solution for me was to turn off laptop, press the NOVO key, (reset and systems start, small button next to the powercord) and start up in bios mode.

In functions change the fn/fx option from "hotkey" to "legacy"

4

It depends on the manufacturer, and sometimes even on the model. Some keyboards have a physical switch hidden somewhere, some keyboards support pressing fn+caps, others require changing a setting in the bios.

The last resort, which is far from ideal but works on all models, is the software approach using AutoHotKey.

4

Some Microsoft keyboards will recognize this keystroke as a toggle: “Fn” + “Caps”

2

I had the same issue with a Logitech K290 Comfort Keyboard keyboard where for some reason it appeared that Logitech had decided for me that I would be better off with the keys switched.

Once I downloaded the setup software (SetPoint) I was able to untick "Swap F key functions" and it went back to normal behaviour (thankfully, as with software development the last thing you want is to keep choosing that you actually want the function key you pressed!).

2

All you have to do is to search for Windows Utility Center or Mobility Center. To get this option press Windows+X which gets you a a popup menu in the left corner of the screen. From there select Mobility Center or Windows Utility Center, and from there assign for your function keys.

Screenshot

  • 3
    "assign for your function keys", assign what? Is there an option there to invert the Fn key? – Arjan May 15 '16 at 9:53
  • Some manufactures add a custom option here to invert the fn key. – BeeOnRope Aug 9 '16 at 2:56
2

For HP, press the F10 key to open BIOS Setup when starting the computer, then navigate to find Action Keys Mode, and toggle the selection.

  • 1
    On my HP EliteBook the default setting is also that the fn button is inverse (i.e. when you press any of the function keys, like F1 for help or F5 to refresh, then instead of triggering the Funtion-keys, it changes the volume or something random), very annoying. I noticed my fn key can be 'locked' so that it would trigger the f-keys correctly. Holding my Shift+fn key locks the fn key so it is inverse. My fn key has a background light to indicate when it is locked. – Spyder Aug 7 '18 at 13:53
1

You need to restart (to enter in BIOS) your computer to change this.

While first black screen comes Press F2 (this may differ in your laptop).

If a bios screen (may be unknown to you) appear then find Function Key Behavior select Multimedia Key First or Function Key First.

Function Key First

This is the default option. Press any function key to perform the associated function. For multimedia action, press Fn + the required multimedia key.

Multimedia Key First

Press any multimedia key to perform the associated multimedia action. For function, press Fn + the required function key.

1

On my Samsung Notebook 9 Pro, there is a "FN Lock" key to the right of the F12 key that reverses the FN buttons. It lights up like the Capslock key when it is activated so you always know when its on.

1

Samsung laptops have Fn Lock key between F12 and PrtScr / Insert.

Though the result is slightly different - it does not revert function of Fn key, but works as if it was always on (unlike Caps Lock).

0

On my Vaio, there is a "Num Lk" button. Press that and the numeric pad is activated, press it again and you can use the keys as before ("m" instead of "0", "j" instead of "1", etc.).

It took me a while to find it! :D

  • 1
    This is a different issue than what the question asks about. – fixer1234 Jun 7 '16 at 19:27
0

On Dell machines, this is a very trivial process.

On boot, hit F2 and enter the Setup Utility. Go to Advance > Function key behavior > Select Multimedia key, and you should find what you are looking for.

protected by Community Dec 23 '16 at 13:32

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.